66

I would like to remove the bubble notifications of Spotify that are shown when a new song is being played. This is quite distracting while you are working.

I still like the integration within the volume menu.

Ubuntu Version: 14.04

Spotify Version: 0.9.10.17.g4129e1c9

108

Exit Spotify, then edit ~/.config/spotify/Users/[Spotify user name]-user/prefs and set ui.track_notifications_enabled=false

  • 1
    No @Jobin, $USER would be the Ubuntu user name, not the Spotify user name. I will revert your edit. – Jos May 26 '14 at 9:40
  • 1
    I have modified the prefs file as you have pointed out, but when Spotify is restarted, it modifies the prefs again removing the ui.track_notifications_enabled=false – Israel Varea May 26 '14 at 9:45
  • 1
    Modified again and now it is working. It seems that I was modifying the file while spotify was running or anything else. Anyway, the solution you've propose is working for me now! – Israel Varea May 26 '14 at 10:10
  • 4
    It works! (I'm on Ubuntu 14.04 with Unity) Funny that we have to go to a config file to do this simple preference change... when will GUI's ever learn? – modulitos Jun 28 '14 at 8:40
  • 7
    Unfortunately this also disables a part of the mpris d-bus interface which normally provides things like "currently playing" information. – exic Jul 31 '14 at 8:27
44

In recent versions of Spotify, you can disable the notification inside the GUI itself.

Go to "Settings" and then "Display Options" and toggle the "Show desktop notifications when the song changes" option.

Display options for Spotify

  • 2
    Using Ubuntu 18.04 and the other answer's dir structure didn't exist. This is the correct answer. Thanks. – Force Hero Mar 16 at 7:42
  • I cannot find this settings page in KDE (the top toolbar is not visible) – vedant Jun 25 at 10:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.