12

I need some assistance, I have 2 laptops, a Toshiba and a DELL XPS M1330, the problem is using my DELL laptop, when I use the HDMI cable to use the TV as monitor the display works fine however the sound only work in the laptop speakers I can't use the TV speakers.

When I go to "Sound" settings to select the HDMI in the "Play sound through", I can't select the HDMI because it never show up. I can only see, "headphones and speakers".

So as a summary the, display works but the sound it doesn't in the TV. Any ideas?

  • This sound completely foolish but when you check sound options with Dell laptop is HDMI cable attached at both ends in respective ports and display is on? – The Dentist Feb 23 '15 at 10:27
8

I follow the below workaround whenever I connect laptop to a TV:

  1. Connect HDMI cable to TV and switch on the TV.
  2. Run the below command on a console (It worked without sudo)

    pulseaudio -k
    
  3. Open Sound settings, you should see "HDMI/Display Port" entry under Output tab.

  • this is works on ubuntu 14.04 using my r9 390. thanks – Gujarat Santana Jun 15 '16 at 20:50
  • I love you bro! – yUdoDis Oct 30 '16 at 16:11
0

It seems that your laptop has dual graphics which may need you to install the Nvidia binary driver and Bumblebee from this guide: https://wiki.ubuntu.com/Bumblebee

  • thanks for the help, I tried the steps mentioned in the link however the issue remains. – Oso May 26 '14 at 16:07
  • Not sure why you suggest installing NVIDIA binaries -- nothing in the Oso's question seems to suggest this is an NVIDIA card. I believe the Dell he describes, the XPS M1330, has integrated Intel GMA graphics (cnet.com/products/dell-xps-m1330/specs) – cboettig May 28 '15 at 4:47
0

To get HDMI audio working on Ubuntu, please download the deb file for your version of Ubuntu from this link:

https://code.launchpad.net/~ubuntu-audio-dev/+archive/ubuntu/alsa-daily/ and install it via cli or the software centre.

  1. For older packages go to page: https://code.launchpad.net/~ubuntu-audio-dev/+archive/ubuntu/alsa-daily/+packages
  2. Then force reload alsa using the following command : sudo alsa force-reload
  3. After that, select HDMI from the sound menu as shown below (for me this option appeared only after installing the above mentioned package)

    enter image description here

Please note HDMI audio function tested on Intel graphics only on a Lenovo Flex2 14 laptop

  • No luck when trying this on ubuntu 15.04... – cboettig May 28 '15 at 4:43
  • 1
    No luck trying this on ubuntu 18.04 – kfsone Jul 21 '18 at 23:15
-1

Try the following:
Reinstall Alsa and Pulse Audio

Open an Terminal (CTRL+ATL+T).

Try to reinstall pulse audio and Alsa, open terminal and enter the following commands:

Purge Alsa and Pulse audio using the command:

sudo apt-get remove --purge alsa-base pulseaudio

Now install again Alsa and Pulse Audio:

sudo apt-get install alsa-base pulseaudio

Then, reload Alsa:

sudo alsa force-reload

Done, if it is not working try the following:

 sudo add-apt-repository ppa:ubuntu-audio-dev
 sudo apt-get update
 sudo apt-get dist-upgrade

Pleas note, that driver is NOT updated for Ubuntu 14.04 yet.

  • I tried your solution but increased problems than solving it. – Fooo Oct 3 '14 at 6:42
-3

I had the same problem. Pulseaudio was not running at startup because my home directory was owned by root. I changed the owner and the sound came back.

  • -1 Explain the process of taking ownership of your home directory. If someone ran sudo chown -R $HOME without thinking, they could break their system. – wjandrea Nov 3 '16 at 22:24

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.