26

I'm using Ubuntu Maverick (Gnome), a month ago I updated like usual whenever Update Manager informed me of new updates. The thing that happened is that a program called kdewallet got installed on my machine, and every time I try to do something that requires password like svn, it pops up and starts getting really annoying. How can I get rid of it? It's not even in the Synaptic Package Manager.

  • You tagged it "kde", are you using Gnome or KDE? (just to be sure, kde could be a dependency of an other program) – Lekensteyn Jun 6 '11 at 8:48
  • As far as I know, Ubuntu uses Gnome and Kubuntu uses KDE. Is that right? and I don't really know why a program called kde-something is running on my computer! – David Weng Jun 7 '11 at 0:29
25

KDE 5/Plasma 5.8:

Add the following lines to the end of ~/.config/kwalletrc

[Wallet]
Enabled=false

Restart Plasma.

KDE4:
KDE Wallet is a core part of KDE, it's in the package kdebase-runtime.

To disable it run kcmshell4 kwalletconfig and continue at step 3 or start from the beginning:

  1. Start System setings
  2. Open Account Details
  3. Go to the "KDE Wallet" tab
  4. Uncheck Enable the KDE Wallet subsystem
  5. Click Apply to apply the changes and close the settings window.

To get a list of the programs that depends on the kdebase-runtime package, run:

 apt-cache --no-enhances --no-suggests --no-recommends --installed rdepends kdebase-runtime

On Ubuntu, the output shows just "kdebase-runtime [newline] Reverse Depends:". On Kubuntu, a whole list follows.

  • 2
    I can't find this System settings you're talking about, I'm using Ubuntu, don't know if it's the case in Kubuntu! – David Weng Jun 7 '11 at 0:26
  • 1
    @David Weng: try running the kcmshell4 kwalletconfig command directly. Could you paste the output of apt-cache --no-enhances --no-suggests --no-recommends --installed rdepends kdebase-runtime on paste.ubuntu.com and add that link in a comment? – Lekensteyn Jun 7 '11 at 7:34
  • This works for some applications but not chrome. I think because there are multiple kwallets floating around. See superuser.com/questions/994551/… – jozxyqk Nov 2 '15 at 2:30
  • This doesn't work anymore in (K)Ubuntu 15.10. – Paŭlo Ebermann Feb 5 '16 at 13:34
  • 1
    In Plasma kcmshell5 kwalletconfig5 worked for me. – zoechi Oct 4 '16 at 7:36
9

I got rid of the "KDE Wallet System" dialog (whenever I started Chrome) as follows:

  1. Edit ~/.config/kwalletrc (see note below), and add

    [Wallet]
    Enabled=false
    
  2. Kill the kdewallet daemon:
    pkill kdewallet5 (or killall kdewallet5)

I found this option when I looked through the source code (on kde.org or at the Github mirror).

If putting kwalletrc in ~/.config does not work, then your system probably uses a different directory for storing configuration files. The config file is created in a directory identified by QStandardPaths::GenericConfigLocation, so I used qtpaths to look up the path (~/.config = /home/rob/.config in my case):

$ qtpaths --paths GenericConfigLocation
/home/rob/.config:/etc/xdg

Note: if you don't want to completely disable kwallet, but only for Chrome, you can use the --password-store=basic flag as I explained at Disable kwallet popups from chrome. If you start Chrome via a wrapper script or shortcut, I recommend using --password-store=basic in case you need kwallet for something else. I disabled kwalletd instead of using this flag because I develop Chrome, and it's inconvenient to add this flag all the time when I run ./chrome.

(Tested on ArchLinux, but it should also work on Ubuntu. Use sudo apt-get install qttools5-dev-tools if you want to use qtpaths to find the configuration directory).

6

I executed:

  1. Start System settings.
  2. Go to the Advanced tab.
  3. Press KDE Wallet icon.
  4. Uncheck Enable the KDE Wallet subsystem.

OS: Ubuntu 10.04.4 LTS.


In Ubuntu 14.04 (trusty), step (2) is now "Go to Account Details"

3

I use Ubuntu 16.04.LTS and found the 'kdwalletrc' file in this path

~/.kde/share/config/kdwalletrc

Switch the option 'Enable' from 'true' to 'false' to disable kdeWallet

[Wallet]
Close When Idle=false
Enabled=false
  • When I look on my 16.04 system, I see ~/.kde/share/ but there is no config directory. I still have the KDE wallet system prompting me every time I reboot. – John Jun 21 '17 at 4:11
0

To disable kwallet for a specific application you can close the dbus for that application by running it like this

env DBUS_SESSION_BUS_ADDRESS=none chrome 
0

Disable password required notification Kwallet

RESUME

KDE menu => system preferences => notifications => wallet (dropdown) => password required option => show popup (uncheck) => reboot.

DESCRIPTION

I'm spanish and maybe the options could have another translation.

I use KDE Plasma 5.12. Open the KDE menu and search "system preferences" and click on it. Now search for "notifications". At top right of the window you could see a dropdown, in my case, I had already choosen "accesibility" option, then change it and choose "wallet". The last step, click on "password required" option and uncheck show pop up or something similar (at bottom). Save and reboot, done :-).

Hope it helps and you can disable this annoying notifications.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.