2

I recently upgraded a PC that I've used as a fileserver and switched from Ubuntu 12.04LTS to 14.04LTS.

I use a wireless card to connect it to the router and this used to start early in boot sequence with 12.04 so the server processes such as Samba worked okay. Now the wireless card doesn't appear to start until quite some time after I login on the 14.04 install. In all it can take well in excess of 5 minutes before I get a wireless connection.

I have some knowledge of linux and over the years have generally been able to figure things out and fix problems by searching online and working through the problems. This time I'm stuck.

I've run the script from this post about wireless issues My wireless/WiFi connection does not work. What information is needed to diagnose the issue? and pasted the output here http://pastebin.ubuntu.com/7517411/ .

I've also pasted the output from dmesg here http://pastebin.ubuntu.com/7517427/.

My system consists of Motherboard: Gigabyte GA-970 DS3P CPU: AMD 6-core FX6350 Memory: 8 GB Video: EVGA GeForce 210 Wireless: Edimax 7128g Rev 3.0a The wireless car is fairly old and the kernal had the required drivers in 12.04 and as the card does work eventually after boot I don't believe that's the problem. It seems to be that the drivers aren't loaded early on for some reason. The Network Settings are set so that the interface is accessible to all users and start automatically. As I understand it this should cause the interface to be started during the boot process.

As I've indicated I'm not an expert with linux so any help in getting the wireless to start early on and speed up the boot process would be appreciated. I can supply additional information if necessary but may need some instructions in how to obtain it.

Thanks in advance.

Andy

  • Please do: sudo ifconfig wlan0 down sudo modprobe -rv rt61pci sudo modprobe -v rt61pci nohwcrypt=1 sudo ifconfig wlan0 up if it helps we will need to make it permanent. Also are you using a gui with your server? with network manager installed you do not need any extra information in your interfaces file. What country are you in? – Wild Man May 25 '14 at 23:58
  • Thanks for the suggestions. I'm not at home this weekend so I'll try them as soon as I can. I'm in the UK. Does the wireless card need to be – andy May 30 '14 at 21:48
  • Thanks for the suggestions. I'm not at home this weekend so I'll try them as soon as I can. I'm not sure what effect the sudo ifconfig wlan0 down might have. I've tried sudo ifup wlan0 and that results in an error to the effect that there is no such device. It keeps giving the error until the point at which the Network Manager icon in the taskbar shows an unconnected wireless icon. That seems to roughly correspond to the point in the logs where the driver rt61pci is loaded. – andy May 30 '14 at 22:07
  • There is a line in the modules file that has an alias for r61pci but it's not just a simple link to wlan0 but more complex that looked like it's an expression for matching a number of different patterns to the same driver. I can't remember exactly what line was, I'll check when I'm at the PC again. My Ubuntu installation does have a gui. I cut my IT teeth with Windows so I prefer having a gui for a lot of tasks. I'm in the UK. Does the wireless card need to be told what country profile to use? – andy May 30 '14 at 22:08
  • Their is a country code for each country that should be set when the driver for your wireless device is installed. – Wild Man May 31 '14 at 3:36
1

I managed to get this working after doing two things.

First as the country code wasn't being set initially I did sudo iw set GB to set it to the UK.

I also did a comparison with a Debian installation where the wireless came up before logging in and the only difference I found was the /etc/network/interface file. I commented out the entry for wired ethernet card and left only the one for the loopback interface and it worked.

I think that it was probably the entry for the wired ethernet card in the interfaces file that was causing the problem. I think that this was done in the initial install as I didn't add it. My guess that this was causing the system to waiting for the wired interface to come up but it eventually timed out and then continued with the boot and that commenting out the entry leaves it to the Network Manager to handle the network and it switches over to the wireless card once it determines that the wired card isn't connected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.