16

On a relatively new installation, Thunar has become the default file browser simply by using it.

While I can open Nautilus easily enough, I'd rather it remained as the default file browser(especially when I choose to view files in dual pane).

How can I change my default file manager?

4
  • you can set your preferred applications in the preferences sub-menu of the gnome menu. Commented Jun 6, 2011 at 8:06
  • 1
    No you can't. That is a seriously lame and half baked tool which only allows setting Web Browser, Mail Reader, Multimedia Player, Terminal Emulator and 2 Accessibility settings. Why one needs 4 tabs to do 6 things beats me as being design madness. Commented Jun 6, 2011 at 13:20
  • hmm, why don't you get rid of thunar?, other thing you can try is to use ubuntu tweak and chnage there the default file browser Commented Jun 6, 2011 at 20:02
  • See also: How to use as default nautilus in XFCE?
    – Wilf
    Commented Nov 11, 2014 at 23:25

6 Answers 6

19
+100

Another method to set nautilus as default using GUI :-

  1. Click on the top-left Xubuntu logo, it will display a menu

  2. Select SettingsSettings manager

    settings manager menu

  3. The Settings window will open, Click on the Preferred Applications icon.

    settings manage window

  4. Then click on the Utilities tab and select nautilus from File Manager section

    preferred application window

That's it. Now nautilus becomes your default File manager.

1
  • 2
    But the desktop is still Thunar's.
    – user47206
    Commented Nov 29, 2017 at 13:47
5

I have a simple solution.

Run this command: exo-preferred-applications

I am using Opensuse 11.4 + Gnome 2.32.1

Thunar became default file browser after playing with XFCE, now I back on Gnome. ;-)

Edit: This method has been tested on Ubuntu by Park Jun-Hong and found to work.

4

Although convoluted, I believe this link will help you from help.ubuntu.com:

Default File Manager

Check for the secion titled “Changing Your Default File Manager”

1
  • 5
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Commented Jun 25, 2012 at 2:44
3

I assume this happens in the same way that it can with Dolphin. The fix (at least for 10.10) is to run a few gconf commands to get things back to normal. I suggest you run the following in a terminal:

gconftool-2 --set --type=string /desktop/gnome/url-handlers/file/command 'nautilus "%s"'
gconftool-2 --set --type=bool /desktop/gnome/url-handlers/file/enabled true
gconftool-2 --set --type=bool /desktop/gnome/url-handlers/file/need-terminal false
1
  • 1
    Nope! I restarted after running the commands but Thunar continues to muscle out Nautilus. Testing things just for a few minutes doesn't show any chages at all. I suppose that is both good and bad! Commented Jun 6, 2011 at 13:35
3

Go to "Preferred Applications." I couldn't find this item on the GNOME menu but was able to find it via Gnome-Do just by writing in preferred applications. Once there go to Utilities tab and select Nautilus from there.

Hope this helps someone later on -- I realise this is an old question.

1

The best way to stop that problem (because it's an issue that even solved can resurface anytime) is to get rid of Thunar if you use Gnome/Unity and not Xfce.

From my experience I can say that Nautilus and Thunar are not tuned up to be used one beside the other, both trying to take over each-other's business, changing the desktop and behaving like they were in their "normal" desktop environments (as if Thunar is asking for Xfce and Nautilus for Gnome/Unity). Their parallel use might make sense only for testing purposes. I think most combinations of file browsers are ok, but not that one.

4
  • 2
    I use Nautilus and Thunar side-by-side all the time, without problems. Sometimes Nautilus will try to take over the desktop, but this hasn't caused me any problems and it goes away when I make sure there are no nautilus processes running anymore. Commented Jun 25, 2012 at 2:46
  • This really isn't an answer. More of a very long comment and should be deleted or moved. Commented Oct 28, 2016 at 6:40
  • @KevinBowen - it's also old, just like the question. Are you still having this problem?
    – user47206
    Commented Oct 28, 2016 at 7:57
  • 1
    @KevinBowen strictly speaking, it is an answer. It is suggesting that the OP remove thunar altogether. That is, in fact, an answer to the question.
    – terdon
    Commented Oct 28, 2016 at 10:28

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .