0

Since the upgrade from Ubuntu 13.10 to 14.04, I have problems with my screens.

My video card is a Radeon HD 7870, it uses the fglrx-updates driver. My main screen is a 24" with a resolution of 1920×1200 and the video card is also connected to a 50" 1080p TV. I want to use only the 24" screen at boot, I use xrandr to display the image on both screens when needed.

After the upgrade, Ubuntu displayed the desktop on both screens in extended desktop mode. The size of all the text was bigger, it was ugly.

I searched a solution to this problem and found someone who suggested to use amdcccle in order to define the screen settings. So I configured the 24" as the only screen in amdcccle and rebooted. Now the problem is still present, after every reboot the desktop is displayed in extended desktop mode on both screens, but the text is not zoomed like before using amdcccle.

The problem is the same if I use the screen configuration tool integrated in Gnome Shell.

I can use xrandr at the start of my session to force the resolution but I'm looking for a direct solution.

Update

As suggested in the comments I switched to the open-source drivers. After a reboot the dual-screen is still activated:

Dual-screen

Once I deactivate the TV the display is correct except the window titles which are big:

TV deactivated

Update 2

This behaviour is random, sometimes the text is not zoomed.

  • Have you tried using the open-source drivers? fglrx has always caused problems for me. BTW, fglrx-updates is older than fglrx, but neither officially support 14.04. – user269370 May 25 '14 at 15:00
  • I switched to fglrx-updates because I read that it was more recent than fglrx. I'm going to test the open-source drivers. If I remember correctly, the last time I used it it was slow, moving a window resulted in graphic artifacts. – A.L May 25 '14 at 15:06
  • @user269370: unfortunately, I have the same problem with the open-source drivers. – A.L May 27 '14 at 22:45
0

You could just use xrandr at startup to turn off the other output

find the name of the output you want turned off at the by typing xrandr at the command prompt.

  • Press Super(Win)Key Type startup application
  • Go to add, Give it a name and in command put : xrandr --output LVDS1 --off (replace LVDS1 with the output you want to disable)
  • Thanks but I'm looking for a cleaner solution, since it worked perfectly without work-around with Ubuntu 13.10. – A.L May 25 '14 at 15:16
  • And this won't fix the problem with the windows title which are too big (I tested xrandr from the terminal). – A.L May 25 '14 at 19:10
0

This was fixed with the upgrade to Ubuntu 14.10.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.