17

I have a fresh Xubuntu 14.04 Trusty Thar installation (not upgrade) and I need to change my keyboard layout each time I boot.

These are the contents of file /etc/default/keyboard:

XKBMODEL="pc105"
XKBLAYOUT="es"
XKBVARIANT="cat"
XKBOPTIONS="terminate:ctrl_alt_bksp"

It seems correct to me, but the layout does not follow this file.


Method #1 tried to apply configuration permanently

Each time I boot I got US keyboard layout. If I do:

sudo dpkg-reconfigure keyboard-configuration

All the options that appear are the desired ones:

  • Generic 105-key (Intl) PC
  • Spanish
  • Spanish - Catalan (Spain, with middle-dot L)
  • The default for the keyboard layout
  • No compose key
  • Yes

But each time I boot the machine I get US layout again.

Output of command is:

Your console font configuration will be updated the next time your system
boots. If you want to update it now, run 'setupcon' from a virtual console.
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools (0.103ubuntu4.1) ...
update-initramfs: Generating /boot/initrd.img-3.13.0-27-generic

Method #2 tried to apply configuration permanently

In my Settings->Keyboard->Layout I have ticked the checkbox Use system defaults. If a change to this configuration:

enter image description here

The configuration is applied, but when I reboot I get US layout again. Settings in this windows are permanent, but keyboard layout is US each time I reboot :-$


How can I change my keyboard layout permanently? It's being annoying...

5
  • What are the content of your /etc/default/keyboard?
    – TuKsn
    May 25, 2014 at 22:41
  • @Xubu-Tur XKBMODEL="pc105" XKBLAYOUT="es" XKBVARIANT="cat" XKBOPTIONS="terminate:ctrl_alt_bksp"
    – logoff
    Jun 1, 2014 at 9:47
  • that is what I stated in the end of my question. it is my default configuration, and it didn't work. I tried configuring my layout too, but as I wrote in @Emil answer, it didn't work.
    – logoff
    Jun 3, 2014 at 7:42
  • I added a lot more information to the question, just to be clearest as possible.
    – logoff
    Jun 3, 2014 at 18:42
  • Try this answer from Emils link askubuntu.com/a/113517/265974
    – TuKsn
    Jun 4, 2014 at 17:24

3 Answers 3

3
+50

Try unchecking "Use system defaults" and make sure that in the keyboard layout list the Spanish keyboard is the first. If you have no Spanish keyboard there add it an move it to the top of the list. It worked for me, hope it helps enter image description here

2
  • I added more info to the question. your method works, but when I reboot, layout is changed again.
    – logoff
    Jun 3, 2014 at 18:41
  • 1
    Apparently this is an older problem. Did you check this: askubuntu.com/questions/66096/…? There are more workarounds there, maybe it's worth to try some of them.
    – Emil
    Jun 3, 2014 at 19:31
0

example how to permanently change to german 'de' language:

apt-get install console-common
localectl set-x11-keymap de
localectl set-keymap de
reboot
0

You can use sudo apt-get install console-common and follow steps:

  • choice your mapping (azerty, qwerty ...)
  • choice your country (belgium ...) of your mapping

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.