2

The problem

I have not used my Ubuntu 12.4 (64 bit) netbook for about a year, and yesterday I tried to install one year worth of updates at once. The update did not go smoothly: I had to restart the netbook a few times because the Update Manager behaved strange.

Now I have about a half of the new packages installed, and I cannot go any further because I have two broken packages: libjpeg-turbo8 and libjpeg-turbo8:i386.

I did not have any third-party repositories enabled, but the Unsupported updates (precise-backports) option had been enabled.

What I have tried

When I use sudo apt-get install -f I get an error message:

dpkg: error processing libjpeg-turbo8 (--configure): 
 libjpeg-turbo8:amd64 1.1.90+svn733-0ubuntu4.1 cannot be configured because
 libjpeg-turbo8:i386 is in a different version (1.1.90+svn733-0ubuntu4.3) 

dpkg: error processing libjpeg-turbo8:i386 (--configure): 
 libjpeg-turbo8:i386 1.1.90+svn733-0ubuntu4.3 cannot be configured because
 libjpeg-turbo8:amd64 is in a different version (1.1.90+svn733-0ubuntu4.1) 

I looks like libjpeg-turbo8:amd64 and libjpeg-turbo8:i386 are in a deadlock: neither can be installed/configured because the other has a different version.

I cannot remove the broken packages, because too many other programs depend on them and would be removed too. The Mark for upgrade and Mark for reinstallation options in Synaptic do not work either. Neither does the Force version... menu.

How can I solve the problem?

  • Try running sudo apt-get install libjpeg-turbo8=1.1.90+svn733-0ubuntu4.3 or sudo apt-get install libjpeg-turbo8:i386=1.1.90+svn733-0ubuntu4.1 (You should do another update in the case of the latter command.) – saiarcot895 May 25 '14 at 3:40
  • Thank you very mach for your response! I have just solved the problem, so I will not be able to try your solution. Maybe, it will help to someone else. I'll post the solution that I used in a minute. – Alexey May 25 '14 at 5:41
1

I found a solution here.

I have changed the /var/lib/dpkg/status file manually, and removed two blocks: libjpeg-turbo8:amd64 and libjpeg-turbo8:i386. Then I called sudo apt-get install -f and the problem was gone.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.