9

The sound icon from the top menu bar is missing. It does however appear on the login screen and the guest account. I can still adjust my volume using keyboard keys but I liked the sound icon because it let me control Rhythmbox.

I noticed there are a lot of questions about this issue but all of the answers say to run $gnome-sound-applet & which does not seem to work. Does anybody know how I can fix this?

Edit: running "gsettings reset com.canonical.indicator.sound visible" fixed the problem

13

Run in a terminal:

gsettings get com.canonical.indicator.sound visible

If the outcome is is "false", change it with the command:

gsettings set com.canonical.indicator.sound visible true
|improve this answer|||||
  • Bizarrely, running the first command returned "true" on my system, even though the indicator was missing. Running the second command fixed it anyways. – jmiserez Jan 26 '15 at 10:52
  • It happens to me every time the system boots where the previous session was shut down having the sound muted. Going to System Settings / Sound, I found the Mute option was checked. Unchecking it, or changing the volume form the Sound settings, caused the icon to show up on the Panel immediately. I was looking for a way to automatically unmute the sound at startup, in order to force the icon showing up, but found the gsettings command mentioned by Jacob useful (even though the get command returns true, setting it again had the expected effect), and it retains the muted state. – Simón Feb 21 '16 at 18:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.