14

I've just upgraded Kubuntu from 12.04 to 14.04, and (as expected) there are several annoyances. The first one I've tried and failed to solve is the "popping" sound that is played whenever I change the volume, with the mixer or with the volume keys. I have enough with the OSD, I don't want any sound.

I have "no audio" selected in the notifications setting, but that doesn't help.

Something else I've noticed, and don't remember it was like this before: when a system tray menu is displaying, the volume keys do not work...

  • 1
    Note to those that marked as close, this is not a bug, this is a sound feature that the user wants to remove. When you change the volume it makes a pop sound. It is actually annoying and that is what the OP wants to disable. – Luis Alvarado May 26 '14 at 14:29
11

Press Alt+F2 keys. A small text box will appear at top margin in center of screen with few icons. Type kmix. And now there will be a option of KMix with its logo. Click on it. And look in notification area there should be broadcasting speaker; click on it.You get dialog box with few buttons Select the button with Spanner on it. A window will open named "Configure KMix". In that window on left hand there will be General option. In General option you will uncheck the "Volume Feedback". close window. Right click on speaker in notification area select Quit. And restart KMix as described above. This should solve your problem.

  • Ah... thanks. I had done all this (except kmix was already running, so no need to launch it), but didn't try closing and reopening kmix, I thought "Apply" would be enough. (And, maybe because of my KDE translation, it was not very clear what this particular setting was supposed to do, so when I disabled it and it didn't work I assumed it meant something else.) – Jellby May 24 '14 at 21:01
5

The trouble with GUI-based answer is that they can't be trusted for too long...

Right-click on the tray icon:

enter image description here

Click on "Audio Volume Settings... Alt+D, S".

Disable "Volume feedback" (i.e., the button should be gray, not blue).

enter image description here

Version info:

~$ plasmashell --version
plasmashell 5.8.6
~$ kf5-config --version
Qt: 5.7.1
KDE Frameworks: 5.28.0
kf5-config: 1.0
3

As the new versions of KDE4 (not to mention Plasma5) have some changes in the GUI of settings, another way is the one posted in this answer.

The first solution there for KDE4 (System Settings > Common Appearance and Behaviour > Application and System Notifications > Manage Notifications > Player Settings > No audio output) didn't completely worked for me.

That may or may not be related to this bug.

Anyway, specifically for disabling the sound heard when changing the volume: click the volume tray icon and disable Event Sounds:

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.