1

When I connect the ethernet to my desktop (13.10), it appears to establish a connection but I cannot access any web pages. If I connect the ethernet to my laptop (12.04.4) it works correctly. I have connected to ethernet on my desktop before, but I have recently relocated and I am trying to get it working with my new living arrangement.

DESKTOP (13.10)

$ uname -a

Linux jeffrey-desktop 3.11.0-20-generic #35-Ubuntu SMP Fri May 2 21:32:49 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

$ ifconfig

eth0      Link encap:Ethernet  HWaddr c8:60:00:de:4f:bb  
          inet addr:10.212.9.183  Bcast:10.212.255.255  Mask:255.255.0.0
          inet6 addr: fe80::ca60:ff:fede:4fbb/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7883 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2406 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:841589 (841.5 KB)  TX bytes:240759 (240.7 KB)
          Interrupt:20 Memory:f7f00000-f7f20000 

$ route -n

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         10.212.0.1      0.0.0.0         UG    0      0        0 eth0
10.212.0.0      0.0.0.0         255.255.0.0     U     1      0        0 eth0

$ sudo lshw -class network

*-network               
       description: Ethernet interface
       product: 82579V Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 19
       bus info: pci@0000:00:19.0
       logical name: eth0
       version: 04
       serial: c8:60:00:de:4f:bb
       size: 100Mbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=2.3.2-k duplex=full firmware=0.13-4 ip=10.212.9.183 latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
       resources: irq:52 memory:f7f00000-f7f1ffff memory:f7f39000-f7f39fff ioport:f040(size=32)

LAPTOP (12.04.4)

$ uname -a

Linux jeffrey-Inspiron-3520 3.2.0-61-generic #93-Ubuntu SMP Fri May 2 21:31:50 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

$ ifconfig

eth0      Link encap:Ethernet  HWaddr e0:db:55:84:bc:f0  
          inet addr:10.212.12.5  Bcast:10.212.255.255  Mask:255.255.0.0
          inet6 addr: fe80::e2db:55ff:fe84:bcf0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7035 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2820 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:4817604 (4.8 MB)  TX bytes:444154 (444.1 KB)
          Interrupt:41 Base address:0x4000 

$ route -n

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         10.212.0.1      0.0.0.0         UG    0      0        0 eth0
10.212.0.0      0.0.0.0         255.255.0.0     U     1      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth0

$ sudo lshw -class network

 *-network
       description: Ethernet interface
       product: RTL8101E/RTL8102E PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:09:00.0
       logical name: eth0
       version: 05
       serial: e0:db:55:84:bc:f0
       size: 100Mbit/s
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full firmware=rtl_nic/rtl8105e-1.fw ip=10.212.12.5 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
       resources: irq:41 ioport:e000(size=256) memory:f0004000-f0004fff memory:f0000000-f0003fff
1

Apparently the new network was blocking the DNS servers that my desktop was trying to use.

/edit

Whenever I tried to ping google.com on my desktop I noticed it was hanging instead of complaining about an unknown host. This means that the issue was during DNS lookup.

I started playing around with dig to find the issue. dig google.com was hanging as expected. dig @8.8.8.8 google.com was also hanging, which is odd because Google's DNS is normally very responsive. I decided to take a look at which DNS servers I was using vs the ones DHCP told me to use.

$ nm-tool

Device: eth0  [Ethernet connection 1] ----------------------------------------
  Type:              Wired
  Driver:            e1000e
  State:             connected
  Default:           yes
  HW Address:        C8:60:00:DE:4F:BB

  Capabilities:
    Carrier Detect:  yes
    Speed:           100 Mb/s

  Wired Properties
    Carrier:         on

  IPv4 Settings:
    Address:         10.212.9.183
    Prefix:          16 (255.255.0.0)
    Gateway:         10.212.0.1

    DNS:             208.67.220.220
    DNS:             208.67.222.222

This output shows me that the DNS servers that DHCP told me to use were 208.67.220.220 and 208.67.222.222. However, these were not the DNS servers my desktop was configured to use:

$ cat /etc/resolv.conf

nameserver 209.222.18.222
nameserver 209.222.18.218

I use PIA's linux beta and it had changed my resolv.conf to prevent DNS leaks which is normally not an issue. However, since PIA's DNS servers are blocked on this new network and I could not connect to the VPN because the ports required for PPTP are blocked on this network, it ended up causing all DNS lookups to fail.

I restored my /etc/resolv.conf to its resolvconf managed form and restarted the ethernet network to fix the issue.

$ sudo ln -sft /etc /run/resolvconf/resolv.conf

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.