Is it possible to view 3D models with PDF documents?

There are a number of PDFs which contain detailed 3D models such as this example: http://www.carare.eu/eng/content/download/2718/21413/version/1/file/Macellum_at_Pompeii.pdf

The models are viewable in Windows and OSX but I can't find any way to view them in Ubuntu.

I've tried evince but it doesn't work.

  • What happens when you double click the file? Does evince not work? Have you tried opening via terminal? – Lucio May 24 '14 at 16:51
  • It opens - but I can't manipulate the 3D Model. – Terence Eden May 24 '14 at 18:22


If you can't get it in software center, Check https://get.adobe.com/uk/reader/otherversions/ . Download .deb package.

Adobe dropped Linux support, but still possible to find it here:

Adobe acrobat with 3D view

  • Excellent! Now to try and find how to extract the model :-) – Terence Eden May 24 '14 at 18:25
  • Doesn't have the same functionality than evince? – Lucio May 24 '14 at 21:20
  • @Lucio, I have Evince 3.11.92. I does show only a static projection. Here a message I got in terminal, it could be related: ** (evince:31349): WARNING **: Unimplemented annotation: POPPLER_ANNOT_3D. It is a known issue and it might be implemented in the future.. Sure you notice that 3D tools bar (Acroread) in the center of screenshot I used. It is possible to navigate around the 3d model. – user.dz May 24 '14 at 21:48
  • Linux is no longer an option on the linked page. They removed the deb. – mythsmith Apr 20 '16 at 14:51

You can install PlayOnLinux (sudo apt install playonlinux) and then use the PlayOnLinux GUI to install and run Adobe Acrobat Reader DC:

enter image description here

Within PlayOnLinux, you can then create a file association to PDF files:

enter image description here

Then you can can right-click PDFs from your file manager, select to open with PlayOnLinux, and they will open and display:

enter image description here

This worked for me on Ubuntu 17.10 (64-bit) with PlayOnLinux 4.2.12 and Wine version 1.9.0. There was some little glitch that occurred during the installation process, but eventually everything seems to be working fine.

  • Awesome! It works; thanks! (I'm using Ubuntu 14.04 64-bit) – Gabriel Staples Sep 4 '18 at 6:34

This pdf file seems working just fine to me : Try using Foxit reader, To install it : sudo apt-get install foxitreader
or visit this wiki article about it : Here

  • Foxit does not support 3d objects: forums.foxitsoftware.com/forum/… – mythsmith Apr 20 '16 at 15:03
  • I get this: $ sudo apt install playonlinux Reading package lists... Done Building dependency tree Reading state information... Done Package playonlinux is not available, but is referred to by another package. This may mean that the package is missing, has been obsoleted, or is only available from another source E: Package 'playonlinux' has no installation candidate – Al Lelopath Aug 10 '19 at 16:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.