I need some help from the community on this one. I recently started playing DOTA2 through Steam on my box and decided to upgrade a few of the components for better gameplay. First I added in another 4GB card to bring my total up to 8GB of RAM and I bought a new GPU as well (Radeon R7 260x). I found that my PSU was likely a little underpowered, so I picked up a new Capstone 550w and got that and the new graphics card installed.

I've since noticed several "problems" or symptoms at the very least. Sometimes I get this weird snow on the screen (think turning on an old CRT TV without the coax cable plugged in) but it's very minimal. Overall you can see the picture just fine, but if you look closely at the screen you can see noise in the image (usually flickering red dots all over the screen). Rebooting seems to fix the "red snow" problem. I've also had some random reboots but lots and lots of freezes which only happen when I'm gaming (sometimes in the middle of games, other times just while the game is loading). I've done a BUNCH of searching around, but I can't find any clear indicators as to what my problem might be.

System details:

  • Running the Oz Diamond II-b Unity UE (Ubuntu 13.04 64-bit)
  • AMD Radeon R7 260x GPU
  • AMD Phenom II X6 1045T 6-core CPU
  • 2x4GB Kingston HyperX Red RAM
  • Asus M6A78L-M LX motherboard
  • 120GB Intel SSD
  • 500GB hard drive (can't recall the brand)
  • Capstone 550w PSU

Other Info:
I did try out the new GPU for about 5 minutes with the old power supply (it booted just fine, but suddenly Unity was broken) so I reinstalled the old GPU until I had the new PSU. After installing all the new components, Unity was still broken and nothing I could do seemed to help, so I ended up just reinstalling the OS over it which fixed my Unity problems. The ONLY time I think I've had any of the freezes or reboots has been when playing, or trying to play, DOTA2.

Also I've installed the "latest drivers" from AMD's website for the GPU, but when I go to the Additional Drivers section of System Settings it doesn't show ANY options (no open source or proprietary drivers). Is it something to worry about?

Any/all advice is much appreciated. Thank you in advance!

closed as off-topic by Eric Carvalho, bain, user.dz, Luis Alvarado Jul 25 '14 at 1:31

This question appears to be off-topic. The users who voted to close gave these specific reasons:

If this question can be reworded to fit the rules in the help center, please edit the question.

  • Sounds like ram problems... – Sampo Sarrala May 24 '14 at 17:46

Do a Memory Test & make sure your RAM's are working fine.

So, I had similar issues with a heavy config like this. I thought Ubuntu is having compatibility issues with the hardware I have purchased so ignored & moved on to windows again. But recently I tried it again but the same issues were still there. The issues I had ranged from - chrome keeps crashing, eclipse keeps crashing, steam keeps crashing & all I found in logs were "segmentation faults". I searched on every forum but did not find the exact cause or a fix.

Finally I went to ubuntu's IRC channel #ubuntu & some guys helped me & suggested that I run a Memory Test on my RAMs.

I downloaded MemTest+ http://www.memtest.org/download/5.01/memtest86+-5.01.usb.installer.zip from http://www.memtest.org/

Created the bootable USB & restarted my system. Booted with the USB & the tests started. All tests failed. So turned out that one of my RAM was corrupted & was causing all the crashes. I had two 4Gb corsair vengeance RAMS. Removed the corrupted one & now Ubuntu is running flawless. Not a single crash since I removed the RAM(past 3 days)

Remember when you run memory tests, make sure you cover all combinations & slots. Try with both rams first, then individual rams & even try switching the slots in which the rams are put. Sometimes for a fail test to occur, it takes many hours, so if you have time leave each combination of test running for a while. But in my case as soon as the test started it started showing failure.

Just give this a try.

  • I ran the memtest86+ from the grub menu for 1 hour and 46 minutes with zero errors (completed somewhere between 1 and 2 passes). I'll take a look at the memtest.org link and see what I can make happen. – user284869 May 24 '14 at 22:10
  • did you try different combinations while testing i.e 2 separate tests with individual rams & 1 with both rams? – Nitish Dhar May 24 '14 at 22:12
  • I haven't yet, but I'm starting to think that maybe this is a software issue instead of a hardware one. I tried some video card testing utilities earlier this morning before realizing that I never had these problems with the new memory and the old video card, and I've ONLY had these problems with the Steam client running AND the game running. Otherwise my system is stable :-/ I'm in the process of removing all of the steam files and re-downloading/installing Steam and DOTA2. Fingers crossed this fixes the problem :-/ – user284869 May 25 '14 at 15:55
  • Also, I saw it mentioned somewhere that it MIGHT be a motherboard issue (not having the correct drivers for the new hardware), but I've also read that Ubuntu (linux) doesn't really need to update motherboard drivers manually since the kernel does that automagically during boot. Is this true? Something I shouldn't even bother with then? – user284869 May 25 '14 at 15:57
  • STILL having problems :-/ updated MoBo bios, re-downloaded and installed Steam and Dota2 and for about 3 bot games didn't have ANY problems. ~20 minutes into a live game had it freeze, then froze again trying to get back into that game, and then froze AGAIN after re-joining game just maybe 30 seconds or so in. At first I thought it had something to do with turning on anti-aliasing in the game cause after I turned it off I made it so long without a freeze :-/ – user284869 May 25 '14 at 21:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.