0

I installed GNOME Flashback earlier today because I prefer the old interface. While surfing the web earlier, gnome-panel crashed. I thought it would be no big deal, but it didn't come back like I expected, so I rebooted. Ever since, I have been unable to get it to launch. I can access Unity fine (posting from Unity right now), but both Metacity and Compiz GNOME Flashback sessions log in, show my wallpaper, and my start-up apps load, but no gnome-panel.

I've uninstalled and re-installed gnome-session-flashback (purged on uninstall), no luck. Yes, I even tried turning it off and on again (sorry, had to throw that in there).

/var/log/syslog says that gnome-panel.desktop was killed with signal 6, and ~/.xsession-errors shows that indicator-application main process ended (2x) and then says it stopped trying to respawn it.

Has anyone seen this issue, and if so, is there a solution? Thanks in advance!

  • Sounds like a bug, which should be reported at launchpad.net. – mikewhatever May 24 '14 at 7:22
  • Yeah, I figured I'd check here before I did that just to make sure I wasn't being an idiot and missing something. I'll file one tonight or tomorrow after I try troubleshooting while actually awake... Troubleshooting at 2 AM isn't always very productive. – Andrew May 24 '14 at 22:18
0

EDIT: I broke it again (about 5-10 mins after posting my original answer below)... then I fixed it! Turns out, when I was adding a new app to the Applications menu in flashback using alacarte it happened again, so I went to kill all my .desktop files, and as it turns out I somehow corrupted something in ~/.config/menus.

Specifically, I added an entry to the Internet category, and it created a duplicate Internet entry, and when trying to hide that, gnome-panel crashed.

Let's see if I can do what I want without breaking things...


After taking some more time to troubleshoot the issue, I've found that it's something specific to my user account. I tried logging in as a guest with gnome-flashback (as I should have done originally) and it worked!

I tried clearing all my Unity, Metacity, Gnome, and Compiz settings with no luck. I tried reinstaling flashback, compiz, and making sure everything was up to date. None of these helped. I can only suspect that a file got corrupted somehow in a settings file I didn't know to reset.

Seeing as I'm more familiar with Ubuntu Server than I am desktop, I decided to backup my home directory, delete my user account, and re-create it and restore my documents, music, etc. from the backup.

So far so good. It's working like a charm now. Will it happen again? Maybe (more likely than not with my luck), but hopefully not.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.