I'm seeing people say things like sudo apt-get remove steam and sudo dpkg -r steam but neither are working.

I ran dpkg-query -l *steam* and I get the following:

| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
un  steam          <none>       <none>       (no description available)
rc  steam-launcher     all          Launcher for the Steam software d
un  steam64        <none>       <none>       (no description available)

Not sure if this helps.

The steam FAQ doesn't seem to help either. I'm pretty sure I didn't do any apt-get install for Steam. I downloaded the steam_latest.deb from the website. Any ideas?

Update: I do have what I believe to be the folder in ~/.steam. What I'm wondering now is, if I remove this folder, what else do I need to remove?

  • yeah get rid of that folder, it's not needed
    – mchid
    May 24, 2014 at 0:36
  • I must've succeeded in uninstalling by uninstalling the launcher. It just didn't feel as if I was actually removing if I removed a launcher. The entire folder in ~/.steam contained all the files necessary to launch the application so I was confused as to how I could uninstall properly and wasn't sure if a simple rm -rf ~/.steam would have been enough.
    – Jonathan
    May 24, 2014 at 0:54
  • "~/." files usually only contain user settings
    – mchid
    May 24, 2014 at 0:58

2 Answers 2

sudo apt-get purge steam-launcher && sudo apt-get autoremove 

Post any errors to recieve further assistance.

  • Package 'steam64' is not installed, so not removed Package 'steam:i386' is not installed, so not removed The following packages will be REMOVED steam-launcher* have done this - but doesn't feel like I'm done.
    – Jonathan
    May 24, 2014 at 0:34
  • I think removing steam-launcher must've done the trick. The only thing that remains is that the actual install of Steam in ~/.steam remains so, I'm assuming if I delete this, I'm all done?
    – Jonathan
    May 24, 2014 at 0:45
  • When you run purge, as opposed to remove, you delete the configuration files as well completely removing the program. The remove command leaves the configuration files intact so if you re-install the program all your previous settings will still be in place.
    – mchid
    May 24, 2014 at 0:45
  • Good idea. I'm actually using lubuntu so I'll search with pcmanfm but it has the same functionality as nautilus. I also tried a quick locate steam and halted it before it went mad, I could see I also have a copy of Steam in ~/.local/share/Steam which makes me want to facepalm a little.
    – Jonathan
    May 24, 2014 at 1:02

Try installing Synaptic Package Manager with sudo apt-get install synaptic, then open the program and search for steam. Click the little button next to it and/or other packages you wish to remove and mark it/them for complete removal, then press Apply. This generally does a more thorough job of removing applications.

  • Synaptic doesn't come up with any results. This is odd.
    – Jonathan
    May 24, 2014 at 0:28
  • if synaptic doesn't show results, what's the output of dpkg -l | grep steam?
    – mchid
    May 24, 2014 at 0:34
  • If Synaptic hasn't got any results, you've probably succeeded in removing the program earlier. May 24, 2014 at 0:36
  • @mchid no output.
    – Jonathan
    May 24, 2014 at 0:38
  • You might be able to still run the purge command to remove all of the configuration files. If not it won't hurt.
    – mchid
    May 24, 2014 at 0:41

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .