2

It's 4 GB USB pen drive. Formatted NTFS. USB2. Works fine on windows on the same computer (and others). It has the contents of a windows xp installation disc.

...I just cannot mount it. When I connect it nothing happens but I believe Ubuntu can see it.

Here are some command outputs


last few lines from dmesg

[  164.703187] ieee80211 phy0: rt2800usb_txdone: Warning - Got TX status for an empty queue 2, dropping
[  554.953670] usb 1-4: USB disconnect, device number 2
[  565.092026] usb 1-4: new high-speed USB device number 6 using ehci-pci
[  565.227144] usb 1-4: New USB device found, idVendor=0951, idProduct=1641
[  565.227150] usb 1-4: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  565.227154] usb 1-4: Product: DataTraveler C10
[  565.227157] usb 1-4: Manufacturer: Kingston
[  565.227160] usb 1-4: SerialNumber: 0019B9087CD7A9C1164B005C
[  565.227564] usb-storage 1-4:1.0: USB Mass Storage device detected
[  565.228288] scsi4 : usb-storage 1-4:1.0
[  566.228802] scsi 4:0:0:0: Direct-Access     Kingston DataTraveler C10 8.20 PQ: 0 ANSI: 2
[  566.229160] sd 4:0:0:0: Attached scsi generic sg2 type 0
[  566.229950] sd 4:0:0:0: [sdb] 7825408 512-byte logical blocks: (4.00 GB/3.73 GiB)
[  566.231158] sd 4:0:0:0: [sdb] Write Protect is off
[  566.231164] sd 4:0:0:0: [sdb] Mode Sense: 23 00 00 00
[  566.231904] sd 4:0:0:0: [sdb] No Caching mode page found
[  566.231910] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[  566.237756] sd 4:0:0:0: [sdb] No Caching mode page found
[  566.237762] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[  567.282038]  sdb: unknown partition table
[  567.287030] sd 4:0:0:0: [sdb] No Caching mode page found
[  567.287036] sd 4:0:0:0: [sdb] Assuming drive cache: write through
[  567.287040] sd 4:0:0:0: [sdb] Attached SCSI removable disk

the part concerned with the device from sudo fdisk -l

Disk /dev/sdb: 4006 MB, 4006608896 bytes
255 heads, 63 sectors/track, 487 cylinders, total 7825408 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0066cd1f

This doesn't look like a partition table
Probably you selected the wrong device.

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   ?          63     7825407     3912672+   7  HPFS/NTFS/exFAT

sudo blkid doesn't show the device


Tried to mount it with those commands:

sudo mount /dev/sdb1 /media/somefolder/someotherfolder but it gives

mount: special device /dev/sdb1 does not exist

and;

sudo mount -t ntfs /dev/sdb1 /media/somefolder/someotherfolder

ntfs-3g: Failed to access volume '/dev/sdb1': No such file or directory

ntfs-3g 2013.1.13AR.1 external FUSE 29 - Third Generation NTFS Driver
    Configuration type 7, XATTRS are on, POSIX ACLS are on

Copyright (C) 2005-2007 Yura Pakhuchiy
Copyright (C) 2006-2009 Szabolcs Szakacsits
Copyright (C) 2007-2012 Jean-Pierre Andre
Copyright (C) 2009 Erik Larsson

Usage:    ntfs-3g [-o option[,...]] <device|image_file> <mount_point>

Options:  ro (read-only mount), windows_names, uid=, gid=,
          umask=, fmask=, dmask=, streams_interface=.
          Please see the details in the manual (type: man ntfs-3g).

Example: ntfs-3g /dev/sda1 /mnt/windows

News, support and information:  http://tuxera.com

sudo ntfs-3g /dev/sdb1 /media/somefolder/someotherfolder gives exactly the same output as above.


pmount /dev/sdb1 kingston gives;

Error: device /dev/sdb1 does not exist

please help

edit! "Disks" sees the device!! (the Kingston one) ... but what next? disks output

edit: output of sudo mount -t ntfs -o loop=/dev/loop3 /dev/sdb /mnt

NTFS signature is missing.
Failed to mount '/dev/loop3': Invalid argument
The device '/dev/loop3' doesn't seem to have a valid NTFS.
Maybe the wrong device is used? Or the whole disk instead of a
partition (e.g. /dev/sda, not /dev/sda1)? Or the other way around?
3

Have you tried the Disks application? (Hit Super/Win key, type Disks) It lists all devices that Ubuntu can see. From there you can see what devices are mounted, edit partitions, format.

3
  • !!!! surprisingly it sees the flash drive!!! didn't think of that! ...but I don't know what to do next. May 24 '14 at 16:04
  • ...who gave the guy a minus one!? -_- May 24 '14 at 16:05
  • ...though you shouldn't have posted this as an answer, you should have added it as a comment. (rules are the rules). May 24 '14 at 16:28
3

Maybe before you have to fix your drive. In any case you will need luck.

  1. Check if it is not mounted: df
  2. Try to mount it, maybe something like sudo mount -t auto /dev/sdb /mnt/. Maybe work with -oloop=/dev/loop and ntfs or ntfs-3g on -t

TestDisk

  • apt install testdisk
  • Run testdisk
  • Choose to create a log or not.
  • Choose the device:

    screenshot

  • Partition table type, probably Intel.
  • Advance > NTFS partition (if available) > [Boot] > Repair MFT

ntfsfix

Fix common errors and force Windows to check NTFS

sudo ntfsfix /dev/sdb
1
  • +1. My problem was something else. For my flash drive programs were either unable to mount partitions, or were giving I/O error when making an image. Luckily, I came across this solution and found Testdisk mentioned. I immediately realized it is best if I just focus on making backup of my important data first instead of fixing an I/O error. I used Testdisk and (given that my flash drive was not encrypted or severely damaged) was able to save important files.
    – Firelord
    May 2 '21 at 23:56
1

Try mounting the /dev/sdb (NO PARTITION number) with the loop option. i.e. treat it as a file you are mounting with the loopback, (and of course, the ntfs filesystem type. Since fdisk didn't seem to see a partition table, maybe it doesn't have one!

sudo mount -t ntfs  -oloop=/dev/loop /dev/sdb /mnt

Check the mount options (man mount). There is an offset, which might help since the starting sector is 63. You could read off the data blocks into a file with dd (again, use the offset), and mount the file with loop, or if you are willing to lose the data (what could be important anyway on a Windows installation disk ; ) , you could try to make a new partition table, using the existing 63 start and 7825407 end.

1
  • I feel positive about your answer; it's something I didn't try before ..but still doesn't work. Tried this exact command and it outputs /dev/loop: No such file or directory. ...I looked quickly at this so I tried sudo mount -t ntfs -o loop=/dev/loop3 /dev/sdb /mnt (notice loop3). I put the output in the main question up. (it looks really bad in a comment) ...I ONCE ASKED ABOUT THIS "NTFS signature" here but no answers :( help? May 24 '14 at 16:20
0

Have you tried mounting in read-only mode?

mount -o ro /dev/sdb1 /media/somefolder/someotherfolder
2
  • no good. mount: special device /dev/sdb1 does not exist. thanks. May 24 '14 at 16:02
  • I believe it should be /dev/sdb instead of /dev/sdb1 as "disks" does not show a partition for /dev/sdb1.
    – mchid
    Jun 5 '15 at 8:48
0

It appears there is probably no /dev/sdb1 and there is probably only a single partition /dev/sdb. This is not uncommon.

Open a terminal and execute the following commands:

sudo mount /dev/sdb /mnt

If there are no errors, you can view the device in nautilus:

nautilus /mnt

For read write permission:

sudo chown -R $USER:$USER /mnt
1
  • To be clear, linux sd stands for scsi device, letter behind it correlates founding order. Number after those are partition number, so if you have partition on your device, in linux it is /dev/sdb(n), not /dev/sdb. sdb is second found block device, sdb1 is first partition on that device. Apr 5 '18 at 16:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.