I'm using an Acer Aspire 5750z-4835 and cant get my wireless internet to work. It doesnt even list the network I'm trying to connect to. I'm a noob to linux, any help would be greatly appreciated.

Here's some info from terminal that may help

ubuntu@ubuntu:~$ lspci -nn -d 14e4: 
02:00.0 Ethernet controller [0200]: Broadcom Corporation NetLink BCM57785 Gigabit Ethernet PCIe [14e4:16b5] (rev 10) 
02:00.1 SD Host controller [0805]: Broadcom Corporation BCM57765/57785 SDXC/MMC Card Reader [14e4:16bc] (rev 10) 
02:00.2 System peripheral [0880]: Broadcom Corporation BCM57765/57785 MS Card Reader [14e4:16be] (rev 10) 
02:00.3 System peripheral [0880]: Broadcom Corporation BCM57765/57785 xD-Picture Card Reader [14e4:16bf] (rev 10) 
03:00.0 Network controller [0280]: Broadcom Corporation BCM43227 802.11b/g/n [14e4:4358] 

ubuntu@ubuntu:~$ iwconfig 
eth1      no wireless extensions. 

lo        no wireless extensions. 

ubuntu@ubuntu:~$ rfkill list all 
0: acer-wireless: Wireless LAN 
    Soft blocked: no 
    Hard blocked: no 
  • Please edit your question to add the result of: rfkill list all
    – chili555
    May 23, 2014 at 19:19
  • added rfkill list all results
    – user284635
    May 23, 2014 at 19:25

3 Answers 3


You probably have the correct driver already. Please confirm:

lsmod | grep -e wl -e b43 -e brcm

We hope we only see wl and its dependencies. Does the interface scan?

sudo iwlist eth1 scan

We don't need to see all the results; just tell us if there are some. If not, tell us the message or error. Do you see the Network Manager icon as here? http://www.oulu.fi/it/graphics/nmgui.png If not, please follow this procedure: Lubuntu nm-applet wifi icon missing

We see from your comments that you do not yet have the correct driver. Please insert the install DVD or USB. Go to pool > restricted > b > bcmwl and drag and drop the deb package bcmwl-kernel-source to your desktop. Do the same with pool > main > d > dkms and drag and drop the deb package dkms to your desktop. Now open a terminal and install both:

cd ~/Desktop
sudo dpkg -i *.deb

After it finishes, load the driver:

sudo modprobe wl

Your wireless should now be working.

If you are running from a live USB, then simply go to System Settings at the upper right, then to Software and Updates and select Additional Drivers. Select and install the driver for your Broadcom.

Once we gather more information, I will edit my answer with additional suggestions.


Get this from the link through and connect ethernet cable connected to your computer. https://apps.ubuntu.com/cat/applications/precise/ndisgtk/ It should tell you what to do when you open it.

  • I dont have access to the router, cant providea wired connection
    – user284635
    May 23, 2014 at 19:27
  • So how are you on here? May 23, 2014 at 19:32
  • another laptop running windows connected wirelessly
    – user284635
    May 23, 2014 at 19:34
  • oh. in that case install it as a deb file on your windows computer and open it on a usb on your ubuntu computer. May 23, 2014 at 19:37
  • ndiswrapper is not needed here.
    – chili555
    May 23, 2014 at 19:40

Go to system settings->software & update --> Additional drivers tab. Check if you have BrodCom Wireless driver is available. If not please update your linux by executing this command in ur terminal. Please make sure you have conneced to wired network.

sudo apt-get update

Once you have executed the above command then go Additional drivers tab and check whether BroadCom Wireless driver is installed. If it is installed , there will be two radio buttons check first radio button and click on Apply changes button. Then it will take time to update changes and it required internet connection. Once changes have been applied you can see WiFi option in network connections. create a new wifi network now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .