7

I have been having significant issues with the usability/reliability of my wireless cards. I have tried several fixes over the past few days. I am running ubuntu 14.04 LTS. I go from 1/10 of the speed i should be getting to not working at all. It does drop sometimes as well. (The above is in regards to my PCI RTL8192ce card)

I recently tried to install a usb wifi adapter (RTL8192cu) and I cannot even get that one to connect well enough to use. ( basically shows no "bars" on the wireless icon on the top right)

I have tried to install the realtek drivers from the realtek site but I had a couple errors with the install. (I have the output somewhere if it is needed.) I have tried as well to use the fix found here: https://sites.google.com/site/easylinuxtipsproject/reserve-7 to no avail. I would appreciate your assistance in fixing this. (There may be a question already solving this but I have tried 2-4 fixes over the past 2 days and none worked)

4
  • The Q&A mentions the exact card model for 14.04 thus this is probably a duplicate: askubuntu.com/questions/414974/…
    – fossfreedom
    May 23 '14 at 18:59
  • That was actually the one I tried right before making this post. It didn't work unfortunately. May 23 '14 at 19:16
  • Please do what is in the accepted answer in the link below so we may see the information needed to help diagnose the issue. <askubuntu.com/questions/425155/…>
    – Wild Man
    May 24 '14 at 1:26
  • @fossfreedom In regards to the PCI card that link may help but the USB card will not work without installing one of the available versions from github.
    – mchid
    Mar 2 '16 at 21:47
7

It's a driver issue.

You might want to check out this thread. http://ubuntuforums.org/showthread.php?t=2148130&page=2

https://github.com/pvaret/rtl8192cu-fixes

COPIED FROM GITHUB:

Ensure you have the necessary prerequisites installed:

sudo apt-get install linux-headers-generic build-essential dkms git

Clone this repository:

git clone https://github.com/pvaret/rtl8192cu-fixes.git

Set it up as a DKMS module:

sudo dkms add ./rtl8192cu-fixes

Build and install it:

sudo dkms install 8192cu/1.10

Refresh the module list:

sudo depmod -a

Ensure the native (and broken) kernel driver is blacklisted:

sudo cp ./rtl8192cu-fixes/blacklist-native-rtl8192.conf /etc/modprobe.d/

And reboot. You're done.

4
  • While the link may answer the question, can you please incorporate the essential parts of the answer into the question? Links have a nasty habit of going bad.
    – Kaz Wolfe
    Sep 8 '14 at 5:18
  • I've copied verbatim now
    – Anon
    Sep 18 '14 at 5:38
  • Do I have to rebuild this driver after kernel updates?
    – tvn
    Apr 4 '15 at 16:56
  • 1
    @tvn No, DKMS takes care of that for you.
    – mchid
    Mar 2 '16 at 21:44
1

I have had the same issues, until I installed the DKMS driver via https://github.com/vincent-t/rt8192cu_dkms

My 8192cu is fast and stable since that driver was installed.

1
  • The installation procedure for this solution is much more automated than the other solution suggested on this page. One command sudo make install_dkms is all what is required for installation. Sep 22 '15 at 11:44
0

I also had a problem with connecting rtl8192ce (EdiMax EW-7612PIn V2) from my ubuntu 14.04. Actually the issue was only with APs not supporting N draft (so the old b/g standard). I checked three different boxes and all had the same issue. I had however no issues with the one AP that had N-draft support. The problem was that the default bitrate with old APs was always set to 1Mb/s even though the link quality was 70/70. But I was not even able to ping default gw. So the solution was to issue:

/sbin/iwconfig wlan0 rate auto

Unfortunately I do not see an option in ubuntu NetworkManager to specify bitrate (I do not use configuration from /etc/network/interfaces) so I added the iwconfig command to

/etc/init.d/wifirifi

and issued

chmod ugo+rx
update-rc.d wifirifi defaults

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.