I did a fresh install of Ubuntu 14.04. Everything works great except after hibernate/suspend I am getting a black screen. I can use Alt+Ctr+F1 then Ctrl+Alt+Del to restart and the screen comes back fine.

I am using the open-source X.org X-server drivers.

My laptop is hp pavilion g6, APU A8-3520M with Radeon HD 6620G

What can I do to make screen come back after suspend/hibernation? I've checked some old thread from 2010 where people add a little piece of code to somewhere in the system to force the screen come back or something.

  • 1
    Seems to be this Bug Ubuntu 14.04 blank screen after wakeup from sleep Did you try with installed "Addidtional Driver" for your GPU?
    – TuKsn
    May 23 '14 at 16:44
  • Well, by "additional driver" do you mean the proprietary one downloaded from AMD website? The problem with them is that, if I install them, and open Scilab Advanced CLI, I will be getting a warning like this: "Libegl warning: DRI2 failed to authenticate" But this thread you just posted, does not present any solution? Am I missing something? May 23 '14 at 17:02
  • I'm sorry I got into ubuntu a month ago, is this a terminal command or what? Thanks again :) May 23 '14 at 17:08
  • 1
    Yes you are right syslog, dmesg and xorg.log would be more interesting.
    – TuKsn
    May 23 '14 at 17:52
  • 2
    Check if this works for you: askubuntu.com/a/436389/16395
    – Rmano
    May 23 '14 at 18:40

Killing the process light-locker (discovered by using xwininfo) helped us temporarily, then uninstalling light-locker with dpkg --purge light-locker light-locker-settings fixed it more permanently.

We are using Gnome 3, so this might not be a solution for everybody.

(In general, there's probably a process displaying a black screen that you need to kill; try to find it!)

  • Thank you so much!! You were a lifesaver. I read through at least 30 bugreports and couldn't find a problem. I was using the open-source radeon driver. But after removing light-locker, everything worked perfectly!!
    – user595510
    Jun 17 '17 at 19:27

Which kernel are you using? Check this with uname -r. I am not a fan of the AMD proprietary drivers on Linux. I find lots of issues with them. I prefer running the open source drivers and newer kernels have many new fixes and features for AMD graphics. You can take the OPEN SOURCE ROUTE, or the PROPRIETARY ROUTE.


If you are using 3.13, then try the newer 3.16 kernel

sudo apt-get install --install-recommends linux-generic-lts-utopic

or try the entire Utopic LTS Enablement Stack which is better...

sudo apt-get install --install-recommends linux-generic-lts-utopic xserver-xorg-lts-utopic libgl1-mesa-glx-lts-utopic libegl1-mesa-drivers-lts-utopic

If you are already running 3.16, then try removing the Utopic LTS Enablement Stack

sudo apt-get remove linux-generic-lts-utopic xserver-xorg-lts-utopic libgl1-mesa-glx-lts-utopic libegl1-mesa-drivers-lts-utopic

If none of this helps, you can try the newest stable kernel. This is a bit more tricky, and could cause some issues, but I have been running the linux 4.0 kernel on Ubuntu 14.04 for a while now with no issues.

mkdir linux4-0-4
cd linux4-0-4
wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.4-wily/linux-headers-4.0.4-040004-generic_4.0.4-040004.201505171336_amd64.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.4-wily/linux-image-4.0.4-040004-generic_4.0.4-040004.201505171336_amd64.deb http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.0.4-wily/linux-headers-4.0.4-040004_4.0.4-040004.201505171336_all.deb
sudo dpkg -i linux-headers-4.0*.deb linux-image-4.0*.deb

After installing or removing any kernels, you will need to reboot in order to test them.


You can install the AMD proprietary Catalyst driver fairly easily in Ubuntu 14.04. Simply run

sudo apt-get install fglrx
sudo apt-get install fglrx xvba-va-driver libva-glx1 libva-egl1 vainfo
sudo amdconfig --initial

If you are using multiple AMD graphics cards or AMD dual graphics (i.e.: notebook users), use:

sudo amdconfig --adapter=all --initial

After installing or removing Catalyst, you will need to reboot in order to test.

  • Saved my life...
    – asiniy
    Aug 2 '15 at 19:13

I had this problem that Ubuntu could not load after upgrading from 12.04 to 14.04. After running startx there was just a black screen. I fix it by going to recovery mode and just picking Repair broken packages and check all file systems, but I think only the first option will work.

  • Can you check if you can recover from hibernating on open-source graphics drivers? I am fairly certain that they are terribly faulty. - - - Also, I would appreciate a little more details about the approach you suggested :) Aug 26 '14 at 21:32

Did you turn off the power of the Radeon graphical device? Because I did it and what you describe here was what I experienced. I canceled the VGA power turning off and the standby exit works again for me.

  • @PeterMortensen I opened a meta question about one of your edits. I'm tagging you because it's correct to inform you about this. Aug 17 '16 at 21:54

I'm quite sure it is a kernel bug (I have the same issue with Intel, and it started only 3-4 weeks ago).

Try to install a different (old) kernel and boot with it. Right now in the repository I can see this is the oldest kernel version:

sudo apt-get install linux-image-3.13.0-24-generic
  • 1
    Same here on a Lenovo Latitude T400. It works after I loaded a former kernel at startup. (Press left Shift key while booting to activate Grub.)
    – JJD
    Dec 22 '14 at 22:07
  • what you mean with former kernel ... anyway on my laptop looks working with last updates ( I'm running 14.10 ) Dec 23 '14 at 7:33
  • You can boot your machine with an earlier kernel by pressing the left Shift key at start-up time. This launches Grub where you can select the former kernel. Note that I am still running 14.04.
    – JJD
    Dec 24 '14 at 9:44

I've had the very same problem on Xubuntu 14.10 my Lenovo Yoga.

I've unchecked the 'Configure new displays when connected' checkbox at display settings dialog.

Give it a try - I hope it helps.


After trying many different suggestions, I finally gave up on 14.04 and installed 15.04 and now the problem is gone.

I have installed 15.04 on Lenovo Yoga 2 pro.


Same problem with NVidia card. Light Locker did not fix it. Solution: Make sure to switch to using NVidia screen drivers by first making sure you have a live Internet connection, then

System Tools->Software Updater ->  (Settings) button
[Additional Drivers]  tab

NVidia Corporation:  Unknown          select radio button:
  (*) Using NVIDIA binary driver--version etc. (tested)
  ( ) Using X.Org X server -- Nouveau
(Apply Changes) button, it takes a while to download & install
**restart your computer**

check your install with System Tools->NVIDIA X Server Settings, should be there and come up with the green penguin splash on the tool.

This did the trick for me.


I had the same problem on a Dell Inspiron 3558 with nvidia graphics (GK208M (GeForce 920M) with driver 340.102) with Ubuntu 14.04 (64-bit intel i5).

Earlier I did a software update and kernel version was:

linux-image-3.13.0-144-generic 3.13.0-144.193 amd64
Linux kernel image for version 3.13.0 on 64 bit x86 SMP

Whenever I suspended (closed the laptop lid), it never started, although I could hear the fan start. I saw some posts on increasing hibernate swap memory, but I didn't think that could be the issue because earlier when I purchased the laptop it was working and even after I custom increased my RAM. I installed Ubuntu afresh as well.

It was just after a particular kernel update that it was gone.

So, I updated linux-generic (currently 3.13.0-160-generic), and I tested it with heavy load software and suspension. It works fine now :)

  • You updated the kernel, so in your case it was a bug in the kernel. This is different from OP's device, so it's not the same problem.
    – Zanna
    Oct 7 '18 at 9:59
  • X-server settings also disoriented this once when I update them to with new drivers for nvida(any version > 360 doesn't work). Lightdm problem still occurs for me. Not all kernel updated resolved my problem, but the version i mentioned did, also posted this to ubuntu resolution center. Hope to help. Oct 7 '18 at 10:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.