Getting started with Openstack here. I've successfully imported and launched instances with a cirros image per the Openstack Installation Guide, but when I import UEC images, like this one here and then attempt to launch instances from it, the instance console reports:

Booting from Hard Disk... Boot failed: not a bootable disk

No bootable device.

When importing the UEC image, I've tried specifying both RAW and QCOW2 formats to Openstack, but get the same error.

What am I missing here?


Did you untar the file first? I have used the following UEC image many times:


Set the image format to QCOW2.

  • thanks, I will try using the .img file directly to try to narrow down the problem, but based on the documentation here: docs.openstack.org/image-guide/content/ch_introduction.html it seems like a UEC tarball should be directly supported. – spiffly May 25 '14 at 16:03
  • Thanks, using the *-disk1.img works (I wonder what the .img file in the tarball is for?), but now I seem unable to login to the instance with the SSH key pair I told openstack to associate with the instance. Where is the documentation for these images? – spiffly Jun 2 '14 at 12:48
  • Start looking from here: ubuntu.com/download/cloud Make sure you log in as the 'ubuntu' user - should work fine with your openstack keypair. – Barak Jun 3 '14 at 6:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.