enter image description hereThese errors occur while starting Ubuntu. I am dual booting Windows 8.1 with Ubuntu.

kernel panic - not syncing : fatal exception in interrupt. shutting down cpus with NMI drm_kms_helper : panic occurred, switching back to text console.

Nothing happens and Ubuntu freezes.

  • Did it work before? If so, which Ubuntu version was it? – m132 Jun 9 '14 at 18:44
  • I have used 12.04, 12.10, 13.04, 13.10 and now 14.04. Every version worked fine. Until 14.04 showed this error and froze. It has been installed since the day it was released. It showed this error on May 23, the day i posted this question. – Muddassir Nazir Jun 10 '14 at 9:21
  • What caused it? Did you install any kernel modules or updates? – m132 Jun 10 '14 at 11:12
  • Nothing I am aware of. Mostly I install through software updater. So I don't remember which update caused it. – Muddassir Nazir Jun 11 '14 at 10:11
  • In GRUB menu, select Advanced options for Ubuntu, choose older kernel (not recovery mode) and tell me if it works. – m132 Jun 11 '14 at 13:53

This was probably caused by fixes and features backported from newer kernels.

In GRUB menu, select Advanced options for Ubuntu, choose the last kernel that worked (not recovery mode).

Now you can:

  • Remove new kernel and keep using old one, making your system vulnerable to old kernel exploits
  • Install newer kernel, for which these fixes were made

Easiest way to install new kernel is to download it from kernel.ubuntu.com and install it using dpkg.

First, select the version you want (preferably the newest non-rc one, utopic kernels will work for 14.04 too), then download 3 files:

  • linux-headers-x.xx.x-xxxxxx-generic_x.xx.x-xxxxxx.xxxxxxxxxxxxx_architecture.deb
  • linux-headers-x.xx.x-xxxxxx_x.xx.x-xxxxxx.xxxxxxxxxxxx_all.deb
  • linux-image-x.xx.x-xxxxxx-generic_x.xx.x-xxxxxx.xxxxxxxxxxxx_architecture.deb

Replace architecture with i386 if you use 32-bit Ubuntu, or amd64 if you use 64-bit one (it has nothing to do with CPU manufacturer!).

Move these files to separate directory, open your terminal, cd to that directory and then run this command:

sudo dpkg -i *.deb

When dpkg finishes, you can reboot, and ensure that you are running the kernel you've installed:

uname -a
Linux m132 x.xx.x #1 SMP Tue Jun 10 00:45:23 CEST 2014 x86_64 x86_64 x86_64 GNU/Linux

Remember, you'll have to update kernel manually now, because Software Updates will only install 3.13 patches, as the kernel version never changes after Ubuntu release.

If it still doesn't work, uninstall the kernel you've installed with

sudo apt-get purge linux-headers-3.13.0-24 linux-headers-3.13.0-24-generic linux-image-3.13.0-24-generic
sudo apt-get purge linux-image-extra-3.13.0-24-generic 

Replace 3.13.0-24 with version you want to uninstall (or press Tab key to list installed ones). Second command may throw an error as there's no linux-image-extra for some kernels.

PS: Please, follow these instructions to make a bug report for that faulty kernel, so they can fix it for others :)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.