I want to edit ftp files from filezilla, with gvim

i open options > associated File types in Filezilla and i have =

. /usr/bin/gedit
thtml /usr/bin/gedit
php /usr/bin/gedit

so i should replace by =

. /usr/bin/vim.gnome
thtml /usr/bin/vim.gnome
php /usr/bin/vim.gnome
html /usr/bin/vim.gnome

is it correct?

  • ... Well, I suppose that should work... But why not just make a backup of the old file and try, and just ask here when it seems that it actually doesn't work, in stead of just asking "Does this work?"? – RobinJ Jun 5 '11 at 16:42
  • Oh sorry, actually i have try this solution but it didnt work. When i want to edit the file, nothing happen. – Papachan Jun 5 '11 at 16:48
  • Wait... You mean you just can't edit it? In the way of "When I type something, it doesn't appear on the screen!"? – RobinJ Jun 5 '11 at 16:50
  • it seem vim.gnome is not the correct way to call the gvim editor. Cause after editing options, i cannnot edit a file from a ftp. – Papachan Jun 5 '11 at 16:55
  • I appreciate too : Open file from filezilla to gvim in a new tab – bcag2 Oct 31 '16 at 8:49


. /usr/bin/vi
thtml /usr/bin/vi
php /usr/bin/vi
html /usr/bin/vi


. /usr/bin/vim.tiny
thtml /usr/bin/vim.tiny
php /usr/bin/vim.tiny
html /usr/bin/vim.tiny


Well, as VIM is complaining that it needs a terminal window to be able to start, a solution would be to use the non-command-line version of VIM. Namely, gvim.

sudo aptitude install gvim

And this should be the file association configuration for FileZilla (tested it, and it worked for me):

. /usr/bin/gvim
thtml /usr/bin/gvim
php /usr/bin/gvim
html /usr/bin/gvim
  • hmmm didnt work for me, it seems filezilla can only execute gegit. – Papachan Jun 5 '11 at 17:04
  • Aha! Found the problem :p I opened FileZilal from a terminal window to see what went wrong, and this is what I got: > Vim: Warning: Output is not to a terminal > Vim: Warning: Input is not from a terminal I'll edit my answer with the solution. – RobinJ Jun 5 '11 at 17:12
  • Huh, the "solution" doesn't work after all xD FileZilla is being annoying here -.- Anyway, VI is a program that needs to be run in a terminal window, so iy complained about that. So I though using "xterm vi <file>" would work. Well, it did when I ran it from a terminal window, but not from FileZilla. Haven't given up yet though, I'm looking into it. – RobinJ Jun 5 '11 at 17:16
  • Ok, finally found a working solution xD – RobinJ Jun 5 '11 at 17:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.