8

I have browsed around here and googled for over an hour, but are no closer to a solution, so here goes.

lets start by killing /usr/lib/x86_64-linux-gnu/notify-osd.

I then do notify-send "foo" and it reappears, but nothing shows. Kill it again, but then change volume or brightness, and it reappears and the notification shows.

I have also tried using the python pynotify library, and the DISPLAY=:0 trick, just in case, but it makes no difference.

I have verified that notification-daemon is not istalled, and reinstalled libnotify-bin and libnotify4. The output of dpkg -l | grep -i notify is

gir1.2-notify-0.7  
libnotify-bin  
libnotify4:amd64
notify-osd
notify-osd-icons
python-notify

This is on a fairly fresh install of 14.04, no particular mods.

I have no idea what to try next.

If you do, please speak up! :-)

Edit:

I see that I was not clear about this when I posted this question, but this is an intermittent problem. Notifications stops or starts working seemingly of it's own. I have not been able to perceive a pattern to it. None of the obvious.

I tried all the standard purging and reinstalling procedures but that made no difference.

I have a tiny suspicion that my video setup might have something to do with this, as I have an Nvidia optimus card that I have not been able to set up quite to my satisfaction despite trying rather hard. Perhaps if some compositing "eye candy" feature is used and that feature is not dependable, that may explain the behaviour I'm seeing.

1
  • I do not have such problem on 14.04. Looks like something is missing.You can try re-installing notify-osd. Commented Jun 11, 2014 at 18:15

1 Answer 1

10

FWIW, I checked against my install of Ubuntu 14.04 (64 bit) and have the same dpkg... output that you have, plus a couple of others from other apps being installed.

Try notify-send "summary" "body" and also try with the --urgency=critical to see if that has any effect. The latter is effective when notify-send is being suppressed because a video is playing.

Otherwise, perhaps install a 3rd party indicator which has notifications and see if that works.

Found the following from a comment at this question:

Try purging notification-daemon: sudo apt-get purge notification-daemon then try apt-get autoremove. Make sure notify-osd is installed: sudo apt-get install --reinstall notify-osd and restart.

5
  • 10
    --urgency=critical makes a difference for me. Not sure where I can change what level of notification I'm accepting.
    – dkinzer
    Commented Aug 1, 2014 at 19:21
  • 3
    --urgency=critical works for me too! Finally a clue to the mystery.
    – user284445
    Commented Mar 9, 2015 at 14:36
  • i have a related problem on 14.04. notifyosd shows me a lot of events, but not brightness change. how can i fix it?
    – ViBE
    Commented Aug 28, 2015 at 23:53
  • --urgency=critical also works for me. I think the issue is video playback. on non-critical urgency levels the notifications are not shown when any kind of video is playing. even my youtube music in the background :/ Commented May 27, 2016 at 18:04
  • --urgency=critical works perfectly. Like xeddo said, it seems to have to do with video playback, as notify-send without --urgency=critical doesn't seem to show notifications while a Youtube video is playing.
    – aurelio123
    Commented Nov 28, 2016 at 22:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .