3

Please read the (PS:) at the end of this new post on this specific problem.

I've read carefully This post but still have problems to connect to one of my Bluetooth headset.

I have two bluetooth headsets (SHB71150 from philips, and WeSC Piston along with two bluetooth dongles one from Thrust (bluetooth V3 version) and and Belkin one (bluetooth V4 version).

For both dongles and both headsets Philips SHB7150 and WeSC Piston BT Black I get the same result :

The dongle manages to connect to the headset, but I have no further option in the Volume control to uses the Bluetooth device.

PS : Now things are a bit different : When I try to pair (Either the SHB71150 from philips, and WeSC Piston) the little bluetooth button shows that the pairing is being done but a few seconds later, the pairing is lost.

I've read all the posts related to bluetooth and head sets bu did not find a viable solution.

Could any one give me a hand on this new problem?

  • Is module-bluetooth-discover correctly loaded in pulseaudio? See askubuntu.com/questions/414258/… for details. – Takkat May 23 '14 at 7:32
  • here is the result of the bt-devile -l command : bt-device -l Added devices: WeSC Piston BT black (00:1B:B8:2F:2F:0F) Philips SHB7150 (00:1E:7C:27:A1:59) – Laurent06000 May 24 '14 at 10:57
  • What do you mean by module-bluetooth-discover correctly loaded in pulse (I'm a newbie in this domain). What I can say is the bluetooh headset seems to appair, but I have no option to control its sound ??? – Laurent06000 May 24 '14 at 11:01
  • bt-device -l Added devices: WeSC Piston BT black (00:1B:B8:2F:2F:0F) Philips SHB7150 (00:1E:7C:27:A1:59) bt-device -i 00:1E:7C:27:A1:59 [00:1E:7C:27:A1:59] Name: Philips SHB7150 Alias: Philips SHB7150 [rw] Address: 00:1E:7C:27:A1:59 Icon: audio-card Class: 0x240404 Paired: 1 Trusted: 1 [rw] Blocked: 0 [rw] Connected: 1 UUIDs: [Headset, AudioSink, AVRemoteControl, Handsfree, PnPInformation] – Laurent06000 May 24 '14 at 16:09
  • I've added the following lines to /etc/pulse/default.pa ;### Automatically load driver modules for Bluetooth hardware .ifexists module-bluetooth-discover.so load-module module-bluetooth-discover .endif. In fact the command : pactl load-module module-bluetooth-discover works fine and allows me to add the headset to the available output, but only once.. This is not a long term solution – Laurent06000 May 25 '14 at 1:14
0

Had the same problem fixed it with:

pactl list cards short

to get the device id, then I did:

pactl set-card-profile X a2dp

where X is your device id

found it by reading No A2DP streaming audio from 12.04 to Bluetooth headset

  • 1
    Please don't post duplicate answers. askubuntu.com/a/519201/88802 – gertvdijk Sep 2 '14 at 16:09
  • pactl list cards short gives me : 0 alsa_card.pci-0000_01_00.1 module-alsa-card.c 1 alsa_card.usb-045e_USB_camera-01-camera module-alsa-card.c 2 alsa_card.pci-0000_00_1b.0 module-alsa-card.c but I do not understand what to do with your pactl set-card-profile X a2dp command – Laurent06000 Sep 24 '15 at 2:28
  • I already tried to change my USB bluetooth dongle from a Belkin to a Thrust one, to change the USB port. Nothing works and I am 100% sure it worked perfectly some weeks ago. – Laurent06000 Sep 24 '15 at 9:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.