5

I try to install Ubuntu 11.04 on my laptop using thumb drive, but it fails with though I use the standard Startup Disk Creator utility.

Laptop model:

DELL Studio 1536

What is the problem

stdin: error 0

/init: line 7: can't open /dev/sr0: No medium found

...

...

...

What is the problem, what did I wrong or what's wrong with boot loader?

Sultan

  • Did you setup BIOS to boot from USB-drive? – Takkat Jun 5 '11 at 14:18
  • Yes I did, I can even select boot device – sultan Jun 5 '11 at 14:21
  • I've mounted ISO image from my home directory under the BusyBox shell, so the question is how to start the installation process from this stage? – sultan Jun 5 '11 at 14:33
  • please insert the answer in your question as an answer and then you can accept it :) gets you a bit of rep and shows others that there is an accepted answer! – Rinzwind Jun 5 '11 at 15:43
2

Try copying the whole text it's more helpful that way:

"If you got this bug, when you boot from USB, press F6 then edit the boot option:

Remove this:

file=/cdrom/preseed/ubuntu.seed

Add these:

live-media-path=/casper/ ignore_uuid

Full sample:

append boot=casper initrd=/casper/initrd.lz live-media-path=/casper/ quiet splash ignore_uuid -- If you don't want to edit every time you boot from USB, you can edit this file in USB: /syslinux/text.cfg"

https://bugs.launchpad.net/ubuntu/+source/usb-creator/+bug/492301/comments/17

3

I've had the same problem the entire night. It's due to the installer not recognizing the USB drive after it's booted to BusyBox.

To fix this, you need to press F6 and modify the boot options. First, remove "quiet splash" from the options and add "break debug" in it's place. Continue installation as normal from this point. Eventually, it will break and you'll be presented with the BusyBox shell, and see plenty of the errors relating to this.

Are you ready for the next step? I promise you, it's an advanced manuver that even Han Solo himself would struggle to attempt.

Step 1: Unplug your USB drive

Step 2: Plug your USB drive back in

Step 3: Type exit and press <Enter>

Step 4: Wait 5-30 seconds and you'll be booted into your Ubuntu graphical installer.

Note: I've verified this works for Ubuntu and Linux Mint. I've been working on this problem for about 4 hours tonight and this is what worked for me, after trying every imaginable method of configuration flags for both the installer and BIOS. I am using a Toshiba Satellite C655D and using a 32GB USB 3.0 flash drive as the installation media.

I hope this helps someone, as I was about to go back to Windows after this nightmare.

  • 1
    Unbelievably this worked for me. I was shocked. Thank you so much! – Tony Tellez Mar 7 '17 at 15:47
  • 1
    2019 checking in. This worked on 18.04. – Jim Jan 29 at 5:11
  • Glad to hear I am still relevant! – ITAdminNC Jan 29 at 18:17
2

This stuff really helped me.

If you got this bug, when you boot from USB, press F6 then edit the boot option: https://bugs.launchpad.net/ubuntu/+source/usb-creator/+bug/492301/comments/17

#Add these:
live-media-path=/casper/
ignore_uuid

1

This may be bug #492301

Try disabling Floppy in BIOS to find out.

  • My BIOS doesn't have this option, I don't know to disable this stuff( – sultan Jun 5 '11 at 14:45
1

Beforte the installation it should tell you that there are still some devices mounted. It will ask you to unmount them. Don't tell it to unmount them as it will also try to unmount your USB drive, wich is the installation medium.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.