0

I have find very odd and crude solution to this entire episode. It is as follows

  1. Start installing ubuntu as usual.
  2. Switch off the monitor
  3. Wait for some time (1-2 minutes) till the HDD access stops .
  4. At this point ubuntu needs some input from the user
  5. Now Switch on the monitor and high chances are that you will see ubuntu normally no out of frequency issues.

Now onwards there will not be any 'out of frequency' issue.

I have successfully installed ubuntu with this workaround.

It is quite useful for newbies in ubuntu. As all other ways are somewhat complex to do especially for a newbie.

Thank you all especially bain who guide me thru the maze.

===================================================================================================The issue i was facing few months ago=======================

I was trying to install Ubuntu 14.04 on p4 . but it was not getting installed due to some issues which i do not understand. it used to give ' Frequency out of range ' message and the monitor used to go into 'stand by mode' . I could never install ubuntu with the old CRT monitor. So i borrowed a latest LCD monitor and was able to install ubuntu successfully. Now i want to use my old monitor so i changed the monitor back to CRT but it again start giving the same error. Experts are requested to guide me about how to change the monitor of the successfully installed Ubuntu. The details are as follows.

My hardware := P4 3.06 MHz / 2 GB ram / 10 Gb hdd totally dedicated to Ubuntu / 2gb swap space. MoBo Mercury P4 266aNDMx 865 Equivalent. Monitor LG CRT Studioworks 500G (8 Years old ) with max resolution of 1024 X 768.
The entire hardware works perfectly under XP.

Error Message :- Out of frequency HF 68.7 KHz
VF 85.0

HF 30 - 54 kHz VF 50 - 120 Hz

The monitor starts a 15 sec countdown with 'Frequency out or range box'

before entering power saving mode.

On the LCD monitor I have changed following settings within Ubuntu before switching over to CRT monitor.

  1. grub GRUB_GRXMODE changed twice once for 800X600 as well as for 1024X768 followed by sudo ubdate-grub each time.

  2. monitor resolution correspondingly was adjusted in ubuntu for 800X600 as well as 1024X768.

The ' Out of frequency ' may be happening due to some different reason. Experts comment.

Regards kanade

XRandr output for LCD is

1360x768 60.0* 
1024x768 75.0 60.0 70.0 
800x600 75.0 60.0 72.0 56.0 
640x480 75.0 60.0 73.0 
512x384 75.0 70.0 60.0 
400x300 75.0 72.0 60.0 56.0 
320x240 75.0 73.0 60.0

Xorg log

Decoded EDID from Xorg log:

Checksum Correct

Section "Monitor"
    Identifier "505E"
    ModelName "505E"
    VendorName "GSM"
    # Monitor Manufactured week 3 of 2005
    # EDID version 1.3
    # Analog Display
    DisplaySize 280 210
    Gamma 2.76
    Option "DPMS" "true"
    Horizsync 30-54
    VertRefresh 50-120
    # Maximum pixel clock is 70MHz
    #Not giving standard mode: 640x480, 85Hz
    #Not giving standard mode: 800x600, 85Hz
    Modeline    "Mode 0" -hsync -vsync 
    Modeline    "Mode 1" +hsync +vsync 
EndSection

According to this page the monitor specs are:

Max Resolution : Manual : 1024 x 768 / 65 Hz
Recommended Resolution : 800 x 600 / 85 Hz
H-Scanning Frequency : 30 ~ 54 kHz
V-Scanning Frequency : 50 ~ 120 Hz
Pixel Frequency : 65 MHz 

Xorg detects pixel clock as 75 Mhz. I think this monitor is capable of displaying an interlaced signal upto 120 Mhz which is why the frequency calculation is wrong.

Hi

I did not tell you earlier that the installation procedure had worked perfectly with same CRT monitor for buntu 7.04 but ironically the issue has started for newer versions!

I have tried totally 4 versions of Ubuntu 7.04, 11.10, 12.10, 14.04LTA.

Any way keep reading

I tried to generate Xorg.conf file on CRT on a terminal tty1, and the server has crashed here is the url of the log file http://paste.ubuntu.com/7521633/ it may be of some help.

Xorg has stopped unexpectedly

Also read this lengthy message may be of any use.

" Your system is proving 3D via software rendering rather than hardware rendering this is a compatibility mode which should display 3D graphics properly but the performance may be very poor. If the problem you are reporting is related to graphics performance your real question may be why X did not use hardware acceleration for your system"

0

Out of frequency HF 68.7 KHz
HF 30 - 54 kHz

Looks like the clock frequency is too high, possibly because it is configured for your new monitor. Try:

$ cvt 1024 768
# 1024x768 59.92 Hz (CVT 0.79M3) hsync: 47.82 kHz; pclk: 63.50 MHz
Modeline "1024x768_60.00"   63.50  1024 1072 1176 1328  768 771 775 798 -hsync +vsync
$ xrandr --newmode "1024x768_60.00"   63.50  1024 1072 1176 1328  768 771 775 798 -hsync +vsync
$ xrandr --addmode VGA1 "1024x768_60.00"
$ xrandr --output VGA1 --mode "1024x768_60.00"
  • It had happened even before i had used LCD monitor. should i try for the lowest end of the resolution in grub ?? – ulkaNCST May 22 '14 at 17:39
  • If your monitor is capable of 1024x768 then you should be able to use that resolution. For some reason it appears the video card is outputting the video at a frequency the montior does not support (not the resolution, but the signal frequency). The commands here will manually add a 1024x768 resolution frequency that should be compatible with your monitor. – bain May 22 '14 at 21:40
  • This should be automatic, I do not know why it does not work for you, perhaps you could boot with the CRT monitor attached, then ssh in remotely and check the contents of /var/log/Xorg.0.log – bain May 22 '14 at 21:43
  • Hello bain Thank you for your guidance i have got the log file with me with CRT monitor. I don't understand anything from it so you have to read it and guide me further it is quite big 50k + so how to send that to you ??? – ulkaNCST May 25 '14 at 12:18
  • Paste it to pastebin then edit your question and add the link. Did you try adding the new mode with xrandr? – bain May 25 '14 at 14:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.