25

So, I am fairly new to xubuntu, and have just made a fresh install. I decided to get steam, so I used the Software Center to install steam, but i am encountering problems. Running steam from the start menu simply brings up a box saying:

Couldn't set up Steam data - please contact technical support

And running it from the terminal produces:

alex@Craptop:~$ steam
Repairing installation, linking /home/alex/.steam/steam to /home/alex/.local/share/Steam
rm: cannot remove ‘/home/alex/.steam/steam’: Is a directory
Setting up Steam content in /home/alex/.local/share/Steam
rm: cannot remove ‘/home/alex/.steam/steam’: Is a directory"

Tried re-installing twice now, and am still getting the error saying it couldn't set up steam data.

  • 1
    try to reinstall steam. – Avinash Raj May 22 '14 at 5:36
  • 1
    Rename the folder /home/alex/.steam – davidbaumann May 22 '14 at 22:53
  • Renaming the folder worked, but steam still isn't working,I will ask a new question that applies to it. – Snail284069 May 23 '14 at 0:22
52

You could try this:

mv ~/.steam/steam/* ~/.local/share/Steam/
rmdir ~/.steam/steam
ln -s ../.local/share/Steam ~/.steam/steam
rm -rf ~/.steam/bin

Which is essentially doing what the steam executable is trying to do, but failing.

  • ln -s ~/.local/share/Steam ~/.steam/steam ? – mcalex Jan 19 '17 at 17:05
  • @mcalex What's your question? Is it about using ../.local/… instead of ~/.local/…? Both work fine in this case. The former creates a relative link (relative to the link location), and the later creates an absolute one. Personally, I prefer relative ones, because they will keep working even if mount the filesystem on a different path, or if I copy/move the entire directory structure. – Denilson Sá Maia Jan 21 '17 at 16:14
  • OK, gotcha. I thought the ../ version needed to be invoked from a certain directory and that hadn't been specified. – mcalex Jan 21 '17 at 17:06
  • Worked like a charm on 18.04. Thanks! – stidmatt Dec 9 '18 at 6:18
  • also works on other Linux, just did this on openSUSE – zeitue Oct 20 at 18:14
10

I know it's been a while and you've probably solved the problem already, but here is a fix that also works.

This error can result if you HAD Steam installed, then did a "nuke and pave" to re-install your system but had /home on a different partition. When you reinstall Linux, your home directory is intact, including your Steam settings, which are in the ~/.steam directory. Remove the directory by opening the terminal and typing:

cd ~
rm -rf .steam

This will delete the settings folder, and Steam should install normally.

  • Saved my day. I just updated from ubuntu 16.04 to 18.04 and was receiving this error, with the accepted answer being of no use. This was the solution for me. – ak93 Nov 4 '18 at 13:55
3

considering that you had already the ff:

  1. /home/.steam
  2. steam launcher

Steps

  1. at terminal:

    $ mv ~/.steam/steam/* ~/.local/share/Steam/
    
  2. using GUI, goto .steam folder, by default its located at /home/.steam

  3. inside the ./steam folder, delete the steam folder.. yeah, theres still another steam folder inside the ./steam folder.. just delete it.

  4. press Ctrl+T at terminal.. $ steam --reset then hit enter

  5. your steam should working and updating.

2

In case none of these work, find out if your home is not on a drive that is mounted noexec. If the drive was mounted with user option, noexec is implied.

If that is the case, steam will also give this error. Solution is to mount the drive with the exec option.

Example /etc/fstab:

UUID=3acfd832-1761-45f8-9b34-24810195172e   /home  ext4 rw,auto,user,sync,exec,dev,suid 0 1

protected by Community Dec 18 '18 at 11:24

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.