1

So here's the thing, I recently installed Ubuntu 14. Everything works fine except the boot loader. I currently have windows 7 installed on another hard drive. But when I boot the machine I get a black screen with a purple border, and then it boots directly into Ubuntu. I tried re installing grub 2 and loading the boot repair but neither worked.

1

You can press the Shift key after the manufacturer screen and before ubuntu boots... Got to have good timing. You could also edit your /etc/default/grub and put a # in front of the GRUB_HIDDEN_TIMEOUT line. Then run sudo update-grub to complete the change. Go to a terminal prompt.

  1. sudo nano /etc/default/grub
  2. Make comment out the line that says GRUB_HIDDEN_TIMEOUT=0 with a # in front of it.
  3. hit control-O (the letter) and enter to save
  4. hit control-x update-to exit
  5. sudo update-grub (to make the changes)

You might also be interested in Grub Customizer. It allows you to easily put backgrounds, change default operating system and the timeouts.

Go to a prompt..

  1. sudo add-apt-repository ppa:danielrichter2007/grub-customizer
  2. sudo apt-get update
  3. sudo apt-get install grub-customizer

Now you might want to use boot repair..

sudo add-apt-repository ppa:yannubuntu/boot-repair
sudo sh -c "sed -i 's/trustysudo apt-get install -y boot-repair/saucy/g' /etc/apt/sources.list.d/yannubuntu-boot-repair-trusty.list"

sudo apt-get update

sudo apt-get install -y boot-repair
  • Thanks man, that worked. Although now windows 7 doesn't appear on the grub screen, any ideas why? – jdstrong95 May 22 '14 at 15:50
  • If you go to your bios when booting and change boot orger so the windows drive boots, does it? – Scott Goodgame May 22 '14 at 17:28
  • Yeah, windows boots fine if I manually boot the hard drive. Grub doesn't recognize it though. – jdstrong95 May 22 '14 at 17:54
0

You can change grub settings with $ sudo gedit /etc/default/grub command. Set GRUB_HIDDEN_TIMEOUT_QUIET variable from true to false then run $ sudo update-grub in terminal.

  • All that did was add a countdown. Still no options to change operating system. – jdstrong95 May 22 '14 at 15:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.