8

I've installed Ubuntu 14.04 on my HP i7 Laptop. It is dual-boot setup along with Windows 8.

  • Ubuntu ----installed on--> SSD 32Gb

  • Windows 8 ----installed on--> HDD

Problem: Internet works much slower on Ubuntu, most of the times web-pages don't even open.

On windows 8, it runs buttery smooth, I have no problem what so ever in windows 8. I have tried to connect with multiple WiFi routers (as I'm in my university) and windows 8 doesn't have any slow browsing problem, only Ubuntu has. So kindly guide me what can I do?

Browsers on Ubuntu:

  • Chromium (Primary)
  • Firefox

One thing to note is that I'm behind a PROXY SERVER. I can't check connectivity on broadband.

What works?

  • Wired Connection (LAN/Ethernet) works fine in Ubuntu 14.04. I seem to have only problem with WiFi connections, & WiFi connections are my 97% main source of surfing.
  • 1
    Please post output of "lspci -knn | grep Net -A2" to your question. – Pilot6 May 16 '15 at 10:37
16

Fix the bug in Debian Avahi-daemon

The slow WiFi in Ubuntu problem could also be related to a bug in Avahi-daemon of Debian. Ubuntu and many other Linux distribution are based on Debian so this bug propagates to several Linux distributions. To fix this bug, you have to edit the nsswitch configuration file. Open a terminal and use the following command:

sudo gedit /etc/nsswitch.conf

This will open the configuration file in gedit so that you could edit it easily in GUI. In here, look for the following line:

hosts: files mdns4_minimal [NOTFOUND=return] dns mdns4

If you find this file, replace it with the following line:

hosts: files dns

Save it, close it, restart your computer. It should fix the slow wireless connection problem for you. If it doesn’t check the other solution.

Works for me. Hope same does for you :) If it dosen't , try other solutions , from here :http://itsfoss.com/speed-up-slow-wifi-connection-ubuntu/

  • This solution solved the problem, I had issues with the entire system. I realised something was wrong when i did the ping command to see whether it was my network or my device. Thanks for a good answer, any idea why this happens? (explanation?) – Denny Sep 27 '16 at 20:37
2

Slow internet is solved by this thread on ubuntu forums for me.

It basically asks you to first check the connection speed after the following command in terminal as a test-

sudo modprobe -r rt2800pci
sudo modprobe -v rt2800 pci nohwcrypt=1

If the connection speed improves, you can make it permanent by opening the conf file in gedit using this command -

sudo gedit /etc/modprobe.d/rt2800pci.conf

When gedit opens, enter the following line in the file -

options rt2800pci nohwcrypt=1

save and close gedit. Internet speed will greatly improve after this.

  • This solution is only for a specific adapter. OP did not give info on what adapter he/she had. – Pilot6 May 16 '15 at 10:36
  • @Pilot6 that's why the test is there. Anyways the only way to answer this is to guess, which is what the other answer did too. – noob May 16 '15 at 14:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.