0

I've have a machine, Dell Poweredge R410 with Ubuntu OS installed in. I'd no problem during installing, however, once it is done it has become annoying as performance is unforgivably abysmal. It runs dead slow that i have to keep typing in vigorously for entering as basic and short a word as password. The machine configuration is as follows:

Memory: 5.6 GiB;
Processor: Intel Xeon(R) CPU E5503 @ 2.00GHz X 4;
Graphics: Gallum 0.4 on llvmpipe (LLVM 3.4, 128 bits);
OS Type: 64 bit;
Disk: 320 GB;

This runs slow in that if i open any application it opens with layer by layer and becomes solid only in a while. I hunch this is an issue with graphics.

Kindly,help me get it run faster to a degree acceptable or suggest me a different version of ubuntu or Linux that is compatible with the hardware. My intention is to use SQL on this machine, primarily.

  • Are you using a server image? – belacqua May 21 '14 at 19:26
  • If the system is slow then it is waiting on something. Either on the CPU (unlikely, a E5503 is modern enough), disk, network, ... To answer what it is waiting on you need to post more information. – Hennes May 21 '14 at 19:35
  • @Hennes I've edited the question. please see to help me out. – user007 May 21 '14 at 20:18
  • *-pci:43 description: Host bridge product: Xeon 5500/Core i7 Integrated Memory Controller Channel 2 Rank Registers vendor: Intel Corporation physical id: 12b bus info: pci@0000:ff:06.2 version: 05 width: 32 bits clock: 33MHz – user007 May 21 '14 at 20:18
  • I've installed 64 bit OS while the above data retrieved by running the command $lshw. – user007 May 21 '14 at 20:20
1

Install a lighter desktop environment like lxde or xfce (preferably lxde). Lxde is light on resources and will give you a faster performance than unity gives you.

  • Thanks for the reply. However, can you rather suggest me lower versions of Ubuntu itself? Reason being that i'm used to Ubuntu and would like to keep to it. – user007 May 21 '14 at 18:35
  • No I not telling you to go away from Ubuntu. Just telling you to install a separate environment within it. If you are really used to Ubuntu, try installing Gnome classic Desktop environment, which is also low on resources. – Ritik May 21 '14 at 18:38
  • Or you can also try reinstalling your copy of Ubuntu – Ritik May 21 '14 at 18:43
  • Could you help me get Gnome classic installed . I've tried using the comment $ sudo apt-get install gnome-session-fallback.This wont work though. Please help me out. – user007 May 21 '14 at 19:50
  • You should use sudo apt-get install gnome-session-flashback – Ritik May 22 '14 at 1:05
0

I'm having a similar Issue ubuntu 14 painfully slow on dell r200

what i have found is you need to add some options to the boot loader i use "mc" with "mcedit" (sudo su) but edit

/etc/default/grub

change:

GRUB_CMDLINE_LINUX="" to GRUB_CMDLINE_LINUX="nofb nomodeset"

hit f2 to save, and f10 to quit then run

update-grub

and reboot

  • It did not work in my case. The machine was still very slow after reboot. – Hilder Vitor Lima Pereira Mar 18 '15 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.