4

I go to ibus preferences in Lubuntu and can add French (Canada), but it's not the Canadian Multilingual layout. I tried installing m17 ibus packages and it adds a bunch of languages but not more French options (other than the French azerty m17 option). I didn't have this problem in ubuntu, just Lubuntu. Please help! Thanks in advance.

1

4 Answers 4

3

You can use setxkbmap to change your keyboard layout settings. Just open a terminal window and type:

setxkbmap ca multix

This will get you a Canadian Multilingual Standard keyboard layout. You can also create a desktop launcher with your keyboard layouts. Create a file named multix.desktop in $HOME\Desktop and open it with a text editor. Add the following lines:

[Desktop Entry]
Encoding=UTF-8
Version=1.0
Type=Application
Terminal=false
Exec=/usr/bin/setxkbmap ca multix
Name=Keyboard Layout
StartupNotify=false
Name[fr_CA]=multix

If you prefer to use the old Canadian French keyboard layout you can use setxkbmap ca and to get back to the US layout use setxkbmap us.

0

For what is it worth in 2022, I just struggled with this.

The name in the Ubuntu 22.04 Input Dialog selection list is Canadian Intl.

You need to go under: Settings> Keyboards> Inputs Sources > Add New

Double click on the Canada French (it is a group and will expand it) And select Canadian Intl.

0

Now in Ubuntu 23.04, it's named Canadian (CSA) instead of Canadian Multilingual keyboard.

I was looking for that for a long time >.<

-1

Install package ibus-xkbd and in your normal keyboard setup (not ibus) choose canadian multilingual, then in choose xkbd as a ibus input method and it will be canadian multilingual.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .