2

I just upgraded Xubuntu on my laptop from 13.10 to 14.04. Emacs' version is 24.3.1. Everything is working fine except the kill-yank system (copy-paste).

To investigate this, I open emacs in my home ("cd; emacs -nw"), create a file ("C-x C-f test.txt"), write a few dummy lines and kill-yank one of them ("C-space C-n Esc-w"). But when I enter the last command ("Esc-w"), the mini-buffer displays the following message:

The mark is not set now, so there is no region

I have no idea what is going on and how to fix this. Any advice?

Here are a few more remarks that can help find the cause of the problem:

  • when I open emacs with a window (that is, without option "-nw"), kill-yank still doesn't work with the keyboard shortcuts (as above), but it does work with the mouse
  • my emacs profile ("~/.emacs") is here didn't change with the upgrade and doesn't have anything related to kill-yank
3

This behavior was due to IBus, as explained here. So I opened a terminal, executed the command ibus-setup and there I changed Ctrl into Alt. I hope it won't break anything, but at least C-<SPC> now sets the mark in Emacs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.