I can hear no sound from my laptop. I installed Ubuntu 14.04 2 days ago and at first everything worked fine, but after a reboot the sound stopped. I searched for 3 hours on google and tried everything I found, but nothing helped.

EDIT: I already tried the solution from the posted thread and it didn't help.

EDIT2: The sound does work on headphones. But it doesn't work on speakers. It's not a hardware problem.

AlsaInfo: http://www.alsa-project.org/db/?f=5b7f589a8cd035feb28d0a87bd1c79a304c5ad29


Try first to reload ALSA:

sudo alsa force-reload

If that won't help, try to reinstall ALSA and pulseaudio:

sudo apt-get remove --purge alsa-base pulseaudio
sudo apt-get install alsa-base pulseaudio
  • No. I still don't have sound. I edited the question.
    – user174653
    May 21 '14 at 7:37
  • 1
    Have you checked if it's muted in 'alsamixer' ? You can mute/unmute it with 'M'
    – user107425
    May 21 '14 at 8:27
  • After trying to reinstall ALSA and pulseaudio as described I now have no sounds settings in the indicator menu. Oct 12 '14 at 21:08
  • 1
    I had the same problem and the cause was that I edited the /etc/pulse/default.pa file and added a module in it. I simply #commented out that entry, logout, login, then it was back.
    – Majal
    Dec 11 '14 at 11:30
  • I also had to run pulseaudio to launch the program
    – wranvaud
    Nov 17 '17 at 3:22

None of the above worked for me on my Ubuntu 14.04. I had a fresh reinstall due to video problems, keeping my home folder alone. Then after a few shutdowns, BAM no sound! Tried all of the above solutions.

Sound Troubleshooting Procedure, worked like a miracle.

The steps are as follows: right from the website, verbatim:

killall pulseaudio; rm -r ~/.config/pulse/* ; rm -r ~/.pulse*

Wait 10 seconds, and then...

pulseaudio -k 

Thats it! This should apprently work for Ubuntu 12 and later. More solutions are available in the link above, but this is the first thign you should try according to the Ubuntu Sound Trouble shooting procedure.


Reinstall Alsa and Pulse Audio

Try to reinstall pulse audio and Alsa, open terminal and enter the following commands:

Purge Alsa and Pulse audio using the command:

sudo apt-get remove --purge alsa-base pulseaudio

Now install again Alsa and Pulse Audio:

sudo apt-get install alsa-base pulseaudio

Then, reload Alsa:

 sudo alsa force-reload

Follow all the process described here : http://www.unixmen.com/2012003-howto-resolve-nosound-problem-on-ubuntu/ (I solved my problem using the Sound Manager and selecting the correct output)


I had a similar problem and I fix it trough alsamixer settings. Enter alsamixer in terminal and then change channel from 2ch to 4ch.


In my case, this problem occurs because of my system start using intel sound driver. Which was not compatible with my Dell laptop. So, I choose 'Do not use the device' and restart my system and problem gone.

Simply follow these steps...

enter image description here

enter image description here

Hope this will help.


I had no sound on headphones jack, but when I tried above to remove alsa and re-install I lost the sound completely instead!

Reinstalling the operating system it will sort the problem out for sure but I think it has to do with the installation of Skype from ubuntu repositories. I have done a fresh install and after installing skype, as it requires 32bit libraries and pulsaudio32, the wasn't any sound coming out from the headphone jack again.

I would suggest to install skype from skype.com website instead. This sorted my problem out.

  • skype is irrelevant to the question above
    – androsfat
    Jan 23 '18 at 21:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.