4

The media buttons for increasing/decreasing the volume of audio output and the mute-button stopped working out of nowhere. The buttons are still recognized by the system, as I can select them to perform the desired action in the gnome control centre, but pressing on of these buttons will do nothing. All the other buttons of the fn-row are working properly.

xev says on button-press:

KeyPress event, serial 37, synthetic NO, window 0x4600001,
root 0x9d, subw 0x0, time 190010, (19,-11), root:(1244,41),
state 0x0, keycode 122 (keysym 0x1008ff11, XF86AudioLowerVolume), same_screen YES,
XLookupString gives 0 bytes: 
XmbLookupString gives 0 bytes: 
XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x4600001,
root 0x9d, subw 0x0, time 190104, (19,-11), root:(1244,41),
state 0x0, keycode 122 (keysym 0x1008ff11, XF86AudioLowerVolume), same_screen YES,
XLookupString gives 0 bytes: 
XFilterEvent returns: False

KeyPress event, serial 37, synthetic NO, window 0x4600001,
root 0x9d, subw 0x0, time 191040, (19,-11), root:(1244,41),
state 0x0, keycode 123 (keysym 0x1008ff13, XF86AudioRaiseVolume), same_screen YES,
XLookupString gives 0 bytes: 
XmbLookupString gives 0 bytes: 
XFilterEvent returns: False

KeyRelease event, serial 37, synthetic NO, window 0x4600001,
root 0x9d, subw 0x0, time 191118, (19,-11), root:(1244,41),
state 0x0, keycode 123 (keysym 0x1008ff13, XF86AudioRaiseVolume), same_screen YES,
XLookupString gives 0 bytes: 
XFilterEvent returns: False

What can I do to get them working again?

EDIT: Ok, so I tried to create a shortcut for "Volume up", using the command pactl set-sink-volume 0 +10%. Binding it to Strg++ worked, but binding it to the "Volume up"-Button has no effect.

  • Have the Function media keys worked previously? Have you tried rebooting if so? (You may already know what is in my answer, i can delete it if required) – Wilf May 20 '14 at 19:49
  • Worked perfect before, and yes, I rebooted. – octavian May 20 '14 at 19:58
  • ok.. have you installed anything or made any changes recently? Could be a bug or something otherwise. – Wilf May 20 '14 at 19:59
  • I installed california, only the .deb, I did not add the PPA, and already uninstalled it (dpkg -r california). – octavian May 20 '14 at 20:03
  • I would not be surprised if that caused the problem - to quote the PPA description: 'Because these builds correspond to the current state of the development source tree, they are untested and highly volatile.'. I should be able to look into this tommorow. Did it uninstall anything? Also, if you do think this did cause it, you could file a bug here. – Wilf May 20 '14 at 22:49
5

I found a solution. Apparently, the values of some dconf keys were mixed up, see here. All I did was:

gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-up
gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-down
gsettings reset org.gnome.settings-daemon.plugins.media-keys volume-mute

Works wonderful now. Thank you all for your help!

2

This happened to me after a system update and restart, causing all of the hotkeys defined in Settings > Keyboard > Shortcuts to stop working. Going into CCSM and turning off the Commands settings fixed most of my hotkeys (mute now works, volume up/down still doesn't work).

0

Go to Keyboard Settings, and then the Shortcuts tab.

You can then find the Volume Up/Down shortcut settings and see if assigning them to the Thinkpad's volume keys works.

Keyboard Shortcuts View

If not, you could assign something else like Ctrl+Up/Down.

  • They are assigned to the buttons "Audio lower volume" and "Audio raise volume", but aren't working. Assigning other key combinations work, but I'd like to use my media buttons again since they worked before. – octavian May 20 '14 at 19:56
  • Have you tried assigning them to the keys (again)? Rebooting can also fix small problems like this - i had problems with the brightness keys on a old laptop. – Wilf May 20 '14 at 19:57
  • I tried that, without any success. Reboot did not help, I also reset the BIOS and did a hardware reset (poweroff, took out battery and pressed the power button for 30 seconds). Doesn't help. – octavian May 20 '14 at 20:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.