20

I have been bothered by this issue for few weeks already. The problem started when I upgraded to 14.04. Parts of my screen are sometimes flickering like shown on 2 videos that links I attach below:

https://www.youtube.com/watch?v=FAg2uGABXQo

https://www.youtube.com/watch?v=ANgAl28P-YE

I was trying to record it with VLC but suddenly when I start recording then ... it stops flickering :)

I have no idea where can I file a bug for this and which package it may be connected with. Please comment with what it may be connected with and how can I resolve this.

I will post any relevant information regarding the packages if need be.

I use nvidia-334 from xorg edgers package ( 334.21-0ubuntu1~xedgers14.04.1 ) but I have also tried others and it's the same issue.

  • Have you tried an earlier version of the Nvidia driver? Or perhaps a later version of the kernel? – bain May 24 '14 at 23:16
  • I may give a try older Nvidia drivers but for the kernel I have tried many versions and now I am running 3.15rc6.. – Patryk May 24 '14 at 23:24
  • I dont recognise that desktop environment - if you login to a standard desktop such as xubuntu or unity does this issue still occur? Have you tried purging the nvidia drivers, deleting the xorg.conf file, rebooting to see if the standard nouveau drivers exhibit this issue? – fossfreedom May 25 '14 at 9:04
  • @fossfreedom I am using Unity. I have now installed nvidia-331 (331.38-0ubuntu7) and I have not noticed any flickering for about 24 hours. I will monitor that issue and report later if that's really the solution. – Patryk May 25 '14 at 21:59
  • Just wondering, what desktop environment are you using? This could be related. – Andrew Stewart May 30 '14 at 23:09
13

This worked for me: http://ubuntuforums.org/showthread.php?t=2243912

Enable Force full screen redraws on repaint option in Workarounds

I had random flickering similar to this (eg. part of webpage flickered in Firefox (hardware acceleration = on), or desktop icon flickered when deselecting it) and this seemed to fixed this issue.

I'm using Nvidia drivers 340.58, Lenovo Y500 GT 750m (single, no optimus, IntelHD disabled).

  • This is also an answer that I have used few days ago (besides installing nvidia-331) – Patryk Nov 23 '14 at 16:54
  • How big is the performance hit by this exactly? – Kaspar Dec 30 '14 at 19:37
  • just a precision: start compizConfig Settings Manager from the menu or by typing "sudo ccsm". And yes, it worked for me too. Thanks – Bob Yoplait Feb 21 '15 at 11:50
  • Worked for me with ZenBook 500 + GeForce 850M. I too am interested in any potential performance hit (I haven't noticed any as of yet) – NuSkooler Mar 18 '16 at 5:36
6
+50

It's a bug in Compiz. If it affects you then you should go here and click on "this bug affects me".

There is a workaround but it can make the system a little bit slower.

Install CompizConfig Settings Manager, then go to Composite and disable Unredirect fullscreen windows.

  • 2
    This is definitely not the same bug. Although it may be related, the problem seen in the linked videos is not tearing, but something else. I tried the fix you suggested (and rebooted), but the problem still persists. – jmiserez Sep 9 '14 at 13:49
6

I have installed nvidia-331 (331.38-0ubuntu7) drivers and for few days now I have not experienced any flickering so probably it was a problem with the drivers (xorg-egders version 334 or recent 337 )

  • 2
    Confirmed working for me. Tried 334/337 after initial install and experienced this exact issue. Rolling back to 331 in xorg-edgers has resolved. – NcA Jun 3 '14 at 15:48
  • 1
    nvidia-331 is working on my 14.10 - no more flickering :D – Jim Ford Nov 17 '14 at 15:09
4

Full instructions based on the other answers here:

  • Install Compiz Config, from a terminal, type:

    sudo apt-get install compizconfig-settings-manager

  • From the launcher, execute CompizConfig Settings Manager

  • Check the checkbox in "Utility -> Workarounds -> Force full screen redraws (buffer swap) on repaint"

It also worked for me, I have a Dell XPS laptop with a Nvidia GT 525m, using Ubuntu 14.04.

  • I just tried this. It's too early to say whether it worked or not so I'll have to come back later to vote. – Isaac Betesh May 11 '16 at 15:35
  • @IsaacBetesh Well? Did it? – Arin Jan 23 '17 at 2:35
  • The screen doesn't flicker anymore. I don't remember anymore whether it was because of this or something else I tried. – Isaac Betesh Jan 23 '17 at 16:22
  • Debian 8 and KDE 4 here. What helped me was disabling certain KDE effects in settings. – LatinSuD Jul 26 '17 at 14:30
-1

I had a very similar issue with 2 GTX 680s in SLI and latest NVIDIA drivers on a fresh ubuntu install in RAID-0. I remembered before Nvidia drivers the screen was very solid and stable with nouveau drivers.

But after Nvidia drivers things happen to mess up.. and screen started to flicker. I remembered selecting a step in Nvidia installer to let the installer generate xorgs.conf file.

I renamed the xorg.conf to xorg.conf.bad-nvidia now things are up and beautiful. Just you dont need that xorgs.conf created by screwed up nvidia installers.

protected by Community Apr 24 '15 at 20:44

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.