I am using the latest version of ubuntu 14.04 in the new lenovo Z510 ideapad laptop. I came across this problem while i was trying to enable my two-finger swipe action. Usually the mouse and touchpad setting will have separate columns for mouse and touchpad as shown here:

from this link

Whereas in my case there is no two parts. Just one, as shown.


Now can I get my settings back to normal, as shown here? Also, is it possible to enable both edge scrolling and two-finger scrolling without the use of third party apps like touchegg? If so, how?

  • have you tried the commands in that link you got the picture from? Just as the options are not shown does always mean that they are not available...
    – Wilf
    May 20, 2014 at 15:57
  • yes. when i try the first command it shows this "Couldn't find synaptics properties. No synaptics driver loaded?"
    – user281989
    May 20, 2014 at 16:10
  • Have you tried searching for and/or installing any drivers? e.g. xserver-xorg-input-synaptics (which may be default, already installed, dunno)
    – Wilf
    May 20, 2014 at 16:14
  • 1
    synaptic is a package manager, not a touch pad driver..
    – Wilf
    May 20, 2014 at 16:43
  • 1
    Basically try running sudo apt-get install xserver-xorg-input-synaptics. Also: help.ubuntu.com/community/SynapticsTouchpad#Troubleshooting
    – Wilf
    May 20, 2014 at 17:02

4 Answers 4


It is possible to get back the touchpad and mouse settings in your control panel.

You can simply install it either from synaptic package manager or by using the following apt command

sudo apt-get install touchpad-indicator

If you are facing the problem with the settings just remove the mouse and touchpad settings file by the following command

rm -fr ~/.gconf/desktop/gnome/peripherals/mouse

Hope this will help you better to resolve your issues.

  • 1
    Package not found
    – Viktor
    Sep 10, 2016 at 9:41

I think it depends on how your touchpad is recognized - it looks the same with my HP Envy x360 15'. You will have more GUI options with gpointing-device-settings or Touchpad-indicator.

sudo add-apt-repository ppa:atareao/atareao
sudo apt-get update
sudo apt-get install touchpad-indicator

Have you checked to make sure the touch pad is active? Also, check and make sure synapics installed like it should have, you can check in the Ubuntu Software Center tool, just open it up, and type synaptics, you should see a small green circle with a check mark in it, showing that it is installed. If it's not there, just install it.

As for enabling both side and 2 finger scrolling, there is way to do that natively in Ubuntu, you would need third party apps to do it.

  • yeah my synaptics is not istalled. there are many downloads avainlabe in the software center. can you tell me which one is the most ideal?
    – user281989
    May 20, 2014 at 16:18
  • according to the link sent in the above comments, my synaptic package manager has been installed.
    – user281989
    May 20, 2014 at 16:59
  • 2
    not the package manager, it's called synaptics, not synaptic, I know it's confusing, it's just 1 letter difference, but that one letter makes a big difference with what you install. So look for synaptics, exactly, you can use synaptic package manager if you installed it, I find it to be easier to find programs in in it.
    – McLovin
    May 21, 2014 at 3:19

This is from the Debian packages so it may be different for you, but I doubt it.

   apt-get install xserver-xorg-input-synaptics

Have you tried using a synaptics configuration file instead? Here is an example of mine in /etc/X11/xorg.conf.d

       Section "InputClass"
       Identifier      "Touchpad"                     
       MatchIsTouchpad "yes"                           
       Driver          "synaptics"                     
       Option          "MinSpeed"              "0.5"
       Option          "MaxSpeed"              "1.0"
       Option          "TapButton1"            "1"
       Option          "VertEdgeScroll"        "1"

Here I just set the speed and vertical scrolling. The settings you want are


I don't see how this is different from using the program you are already using, but it is always useful to know what is going on!

Oops! I didn't see that someone has already beaten me to it! Sorry!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .