1

My ubuntu software center was not working and I was trying to fix it. I ran the following series of commands:

sudo apt-get update

This one failed and this was the result

Err http://extras.ubuntu.com quantal InRelease

Err http://us.archive.ubuntu.com quantal InRelease                             

Err http://us.archive.ubuntu.com quantal-updates InRelease                     

Err http://us.archive.ubuntu.com quantal-backports InRelease

Err http://extras.ubuntu.com quantal Release.gpg
Unable to connect to 192.168.0.2:3128:
Err http://us.archive.ubuntu.com quantal Release.gpg
Unable to connect to 192.168.0.2:3128:
Err http://us.archive.ubuntu.com quantal-updates Release.gpg
Unable to connect to 192.168.0.2:3128:
Err http://us.archive.ubuntu.com quantal-backports Release.gpg
Unable to connect to 192.168.0.2:3128:
Err http://security.ubuntu.com quantal-security InRelease

Err http://security.ubuntu.com quantal-security Release.gpg
Unable to connect to 192.168.0.2:3128:
Reading package lists... Done
W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/quantal/InRelease  
W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/quantal-updates/InRelease  

W: F ailed to fetch http://us.archive.ubuntu.com/ubuntu/dists/quantal-backports/InRelease  

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/quantal-security/InRelease  

W: Failed to fetch http://extras.ubuntu.com/ubuntu/dists/quantal/InRelease  

W: Failed to fetch http://extras.ubuntu.com/ubuntu/dists/quantal/Release.gpg  Unable to connect to 192.168.0.2:3128:

W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/quantal/Release.gpg  Unable to connect to 192.168.0.2:3128:

W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/quantal-updates/Release.gpg  Unable to connect to 192.168.0.2:3128:

W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/quantal-backports/Release.gpg  Unable to connect to 192.168.0.2:3128:

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/quantal-security/Release.gpg  Unable to connect to 192.168.0.2:3128:

W: Some index files failed to download. They have been ignored, or old ones used instead.

Then i ran these commands

sudo apt-get autoclean
sudo apt-get clean

and when I ran the command sudo apt-get autoremove, I got the following result:

"Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run `'apt-get -f install'` to correct these.
The following packages have unmet dependencies:
ubuntu-minimal : Depends: resolvconf
E: Unmet dependencies. Try using -f."

So should I forcefully uninstall ubuntu-minimal : Depends: resolvconf

5
  • 2
    did you run sudo apt-get install -f command? May 20 '14 at 14:55
  • as Raj said , near problem happen for me too I try that and solved May 20 '14 at 14:58
  • 1
    i did run sudo apt-get install -f but it failed E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
    – user283501
    May 20 '14 at 14:58
  • Please edit your question and show us what message sudo apt-get update failed with. Telling us "it failed" is not very useful.
    – terdon
    May 20 '14 at 16:08
  • sudo apt-get install resolvconf Reading package lists... Done Building dependency tree Reading state information... Done The following NEW packages will be installed: resolvconf 0 upgraded, 1 newly installed, 0 to remove and 36 not upgraded. Need to get 54.4 kB of archives. After this operation, 251 kB of additional disk space will be used. Err in.archive.ubuntu.com/ubuntu trusty-updates/main resolvconf all 1.69ubuntu1.1 Cannot initiate the connection to in.archive.ubuntu.com:80 (2001:67c:1360:8c01::18). - connect (101: Network is unreachable) [IP: 2001:67c:1
    – shailesh
    Apr 24 '15 at 6:57
0

I tend to not use/trust sudo autoremove as I have found that when I look at the packages it says are no longer required, I have seen my entire desktop, (when using the MATE desktop), and have experiences with it removing dependencies that I did in fact require, and have had to reinstall some systems as a result, always look at what packages it's removing when you issue that command, because it may have even removes a repository gpg key, and now the install -f wont work because the system wont download from the untrusted repo.

Just the type experiences I have had with the autoremove.

0

No, you are going the wrong way about this. You should instead install resolvconf with sudo apt-get install resolvconf. Removing ubuntu-minimal can leave your system unbootable.

2
  • I tried sudo apt-get install resolvconf but that too failed
    – user283501
    May 21 '14 at 7:43
  • @user283501 edit your question and add the result.
    – Braiam
    May 21 '14 at 17:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.