First time trying out MAAS (want Openstack dev/test under cloud setup using MAAS). I want lab net <-> (eth0) MAAS Region & Cluster server (eth1) [DHCP/DNS] <-> isolated net. I installed via 14.04 LTS installer selected MAAS and after a couple hiccups I believe I have things mostly working (UI available) but I can't get DHCP on the isolated network. One thing that troubles me is that I cannot ping the eth1 address of the cluster server. I would appreciate troubleshooting tips for maas in general, things to look for in logs etc. From the Cluster system I can ping it's own eth1 address but am getting Destination Host Unreachable for others on the (eth1) network.

#cat /etc/network/interfaces
# The primary network interface
# This is an autoconfigured IPv6 interface
auto eth0
iface eth0 inet static
#iface eth0 inet6 auto
address 10.80.xxx.50
network 10.80.xxx.0
broadcast 10.80.xxx.255
gateway 10.80.xxx.1
# dns-* options are implemented by the resolvconf package, if installed
dns-nameservers xxx.xxx.xx.132 xxx.xx.xxx.52 xxx.xx.xxx.41
dns-search xxx.com

auto eth1
iface eth1 inet static
up ip route add via || true   

# ip addr
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
link/ether 00:1e:68:9b:2f:6c brd ff:ff:ff:ff:ff:ff
inet brd scope global eth1
   valid_lft forever preferred_lft forever
inet6 fe80::21e:68ff:fe9b:2f6c/64 scope link
   valid_lft forever preferred_lft forever

#ip route
default via dev eth0 dev eth0  proto kernel  scope link  src dev eth1  proto kernel  scope link  src

1 Answer 1


This stumped me for a bit since it sure looked like eth1 wasn't connected into the right network but I saw all the cables connected. The answer is that I actually hadn't screwed up my network/route setup but that I didn't realize that the udev rules for NIC mapping was different from what I had assumed it actually was. My server's NetMgmt port is actually shares a physical connector between Service Processor and Server. I've recalled and am reinstalling MAAS and things are going much better.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .