1

I am using Ubuntu 14.04, and my Desktop is gone. After I log in, Unity would not start and I am stuck with just a working mouse cursor.

I have a hybrid AMD-Graphic card and I have removed anything related to fglrx (I think) by using Ctrl + Alt + F1.

I re-installled the xserver, ubuntu-desktop, unity. But nothing works.

I installed compizconfig-settings manager and tried to enable the Unity Plugin package,but ccsm won't' load because I get an error saying No protocol Specified . No application which requires a GUI, works because it says it is not able to connect to the Xserver and X11 initialization failed.

I tried dconf reset -f /org/compiz/ but that throws an error saying Error spawning command line 'dbus-launch .

Can someone please help me and get my desktop back ?

EDIT: I ran DISPLAY=:0.0 ccsm I get

compizconfig - Info: Backend : ini
compizconfig - Info: Integration: true
compizconfig - Info: Profile: default
[690.211258] ata1.00: exception Emask 0x0 SAct 0x7fffffff SErr 0x40000 action 0x0
[690.211315] ata1.00: irq_stat 0x400000008
[690.212031] ata1: SError: { CommWake}
[690.212747] ata1.00: failed command: READ FPDMA QUEUED
[690.213444] ata1.00 cmd ____<some address>_________________ tag 8 ncq 4096 in

The error continues, I could not write down everything from the terminal. In the end there was some Emask media error and I/O error,dev sda, Bus error(dumpped)

  • Did this start after removing fglrx? – Danatela May 20 '14 at 10:28
  • Try answers here: askubuntu.com/questions/17381/… For me, I wasn't lucky with the answers but you may be lucky. Instead my own solution was based on the fact that I found that the original problem was for one of my accounts. When I logged into another account everything was normal. So my approach to the problem would be to move any valuable personal files from the faulty account to the working account, delete the faulty account and the recreate it and move the files back. – therobyouknow May 20 '14 at 10:55
  • @therobyouknow - I tried all the options there. The first answer is asking me to start ccsm, but I am not able to load ccsm because I get an error saying No protocol specified. Is there a way to fix this? @Danatela - I never had fglrx in the first place! – user1955184 May 20 '14 at 12:49
  • No idea about the No protocol specified, sorry. Do you have more than one user account set up? If so you can follow my solution above. Otherwise, if you have valuable files, you should be able to get Terminal access Alt-Shift-F1 and or use a Live CD and transfer the files off to a USB pen drive then re-install. – therobyouknow May 20 '14 at 13:34
  • @therobyouknow how can I backup my valuable files in the ctrl+alt+F1 tty so I can re-install? I only have one user so your solution won't work for me :( I think I need to just go back to the drawing board but I can't loose what's on my machine! Help! – gastronomin May 29 '14 at 12:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.