1

I'm having trouble installing Ubuntu 14.04 from flash drive. I can see the options for trying, installing and checking disk for defects but if choose any of them it's just a black screen. I can hear a jingle when I try "Try Ubuntu without installing" and "Install Ubuntu" options but it's still a black screen. I have Intel i5 4570, GTX 750 Ti with 4GB of RAM. I do have Ubuntu 14.04 installed right now but I want to totally reinstall it.

3

Wait longer.

I have an Intel i3-3225, 8 GB RAM, GTX 750 Ti. I booted 14.04 off a 2GB usb stick and chose "Try Ubuntu without installing". I got the black screen and thought I had replicated your error, but after waiting a while the mouse showed up, then waiting a little longer the desktop displayed. So if you haven't yet, try waiting several minutes.

If waiting longer doesn't work, shout down your PC and unplug your graphics card from the motherboard. Your processor model has Intel HD graphics which has better supported drivers than that brand-spankin-new graphics card does. Do your fresh install of Ubuntu on the Intel HD Graphics. When that's done, shut it down and plug your card pack in.

  • Thanks that worked perfectly. I had to use Intel HD Graphics and then manually install Nvidia's GPU drivers. – JoeMBlair May 21 '14 at 22:51
4

This is simple! Took me a while to work it out, but I had the same issue, and it turned out it was using the onboard Intel GPU!

Even if your BIOS has your Nvidia card as default, for some reason, Ububtu still uses the onboard card, so it is actually booting, you just cant see it!

The solution: Go into your BIOS and disable your onboard video. When you reboot, leave the black screen for a few minutes, and the mouse should appear.

This may not working in all situations, but its an easy thing to try first!

  • The solution to disable the onboard video card in BIOS setup worked and it was able to boot for GTX 980 with Ubuntu 14.04. Now it takes the NVIDIA by default and loads properly. – bgth Nov 26 '15 at 9:08
1

Simply start the Ubuntu installation using the Intel IGP (Integrated Graphics Processor) instead (make sure to modify this option in the UEFI Bios). When you finish the installation, download the linux drivers for your graphics card, install them to be able to use your graphics card and you'll have it done.

1

During boot (bios or black screen and white text appears on UEFI.) For MultiSystem LiveUSB, at your chosen boot option in the menu.

  • Press e and add nomodeset before quite splash words.
  • Press F10 and it will continue to boot in non 3d mode
  • Install ubuntu as usual
  • On first boot, use again nomodeset as described in first statement

then;

sudo apt-add-repository ppa:xorg-edgers/ppa
sudo apt-get update & upgrade
sudo apt-get install nvidia-337 #( don't install that before command above)

then;

sudo gedit /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

and change it to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

save & close

then;

sudo update-grub

restart.

0

I had this issue on two machines, both running Debian (so not exactly ubuntu but close). I tried various kernel parameters like nofb and nomodeset but without success.

On one of the machines MicWit's suggestion of disabling the onboard graphics in the bios fixed the blank screen issue but left X unusable. The screen was both blurry and blocky as if the image had been downscaled and then re-upscaled, text was unreadable.

On the other machine MicWit's soloution made no difference but what did work was renaming /lib/modules/<kernel version>/kernel/drivers/gpu , this prevented whatever the borked driver was from loading and fixed the blank screen issue. X11 was somewhat usable after doing this but was stuck at 1024x768.

In both cases after dealing with the blank screen issue I had to install the Nvidia binary driver to make X11 work properly.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.