2

My gnome-shell seems to have only one workspace. I cannot switch to another workspace by using the Ctrl+Alt+Down/Up combination and using the Super Key always shows me one workspace only. If I attempt to open a program in a new workspace using the middle mousebutton i can observe there being 2 workspaces briefly but then the program gets moved to the upper one and the second one disappears. I have already tried to use static workspaces using gnome-tweak-tool. This gives me multiple workspaces, but they all show the exact same content. They are not independent from eachother. Furthermore I have found executing

compiz --replace
gnome-shell --replace

Gives me a gnome-shell with working workspaces.

Edit: Actually the workspace feature just disappeared as I opened a program. So scrap the part about it working.

  • Not happening to me; do you have any extension enabled? – Rmano May 19 '14 at 20:53
  • gnome-tweak-tool says no extensions installed. I have already tried reinstalling gnome-shell twice to no avail. Its always the same. – Zillolo May 19 '14 at 20:54
  • I wonder if trying to run compiz --replace may have interfered with gnome-shell and mutter proper configuration. I don't know what effect that would have if you tried it. Note that gnome-shell only works with the mutter window manager, it will not work with compiz. – Mike Miller May 19 '14 at 22:25
7

I have fixed this problem, by disabling the option "Workspaces on primary display only" in the Gnome Tweak Tool.

Everything works again as expected.

  • having the same problem, this solved my problem – ubugnu Sep 30 '14 at 10:02
  • That seems to have worked for me, after restarting gnome shell. However, I like the feature of only having workspace on the primary display. Is there any other fix? – Thayne Feb 12 '15 at 19:42
  • I have yet to find a fix for this. I know of no workarounds Im afraid. – Zillolo Feb 12 '15 at 19:47
  • same here :-S .... Gnome 3.22.., this solve the issue. – warfares Oct 18 '16 at 21:35
2

I had the same problem when I switched to graphics driver nvidia-331. When I switched back to X.Org (nouveau) driver or to nvidia-331-updates, the workspaces again works correctly.

1

Since you are running compiz, you need to enable the workspaces using the compiz session manager. See the answer on the link below:

http://askubuntu.com/questions/519651/add-workspaces-with-gnome-classic-and-ubuntu-14-04/519718#519718

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.