-1

I have been using xubuntu for a while now on a dual boot with windows. Slowly migrating over as more games become available on linux. I have GTA: San Andreas on both Steam and DVD. The play on linux Steam install is bugged. I finally popped in the DVD and used just the plain Wine 1.6.2 instead of POL to install it and now it runs beautifully, much smoother than on windows.

Now San Andreas is no fun with out my own music, so I started to copy music to the wine directory where San Andreas is installed. However no matter what I do I can get my music to come up in game. I've tried using windows shortcuts to the mp3s (both native windows and wine windows shorcuts), I've tried linux shortcuts, I even dropped the mp3s straight into the User Tracks folder.

Another thing is that it will not save. It will act like it is saving, no errors, but the save game list is always empty, and no save files are created. O_o is there some write/read permissions I need to set to fix both?

After trial and error (Linux Steam, POL Steam, Wine Steam), I got Black Mesa working on POL Steam, and I have Skyrim fully modded on my windows side, and I'm a web coder, so I know computers, but I am still a rather new to linux. Any Help would be appreciated.

EDIT: So I am now on the latest Stable Wine. I reinstalled San Andreas wising plain Wine and my disk, No POL, no Steam. Now it will save the game properly but I still cannot get my music in-game. I have put the mp3s straight into the User Tracks folder that is right next to the save game, and that is the folder in which music goes on Windows, I know it's in the right place. I have the Automatic Music Scan on , and I have Manually scanned for user tracks. Still no Joy. I feel like the guy that just rebuilt his car and engine from scratch but can't get his radio to work....lol

Update: I downloaded the CrossOver Trial and installed the Steam San Andreas used the CrossTies installer.. It runs better, but I still cannot get my user music into the game. Any help would be appreciated.

0

The current version of WINE isn't always the best for a particular program. Also, the version of the game you have can make a big difference.

Looking at the WINE appdb, Version 1.x is listed as Gold, but 2.x is listed as Garbage.

If you are stuck in version 2.x you may have luck with the specific version page, it lists common problems and some workarounds or fixes if known.

  • Actually the game runs better than fine. However after more research I have found out that Wine does not install MP3 support. I have tried with Wine, POL, and CrossOver Trial. None add mp3 support. And I'm also having issues using the shell script I google to convert a copy my mp3's to OGG due to not being able to install FFMPEG in linux. I've read that the issue with both FFMPEG and MP3 is licensing. – Akadine May 24 '14 at 5:31
0

The solution I have come up with is to go back to windows (ugh) on my duel boot, convert the mp3s to OGG in Windows with any free converter, go back to linux and put the OGGs into GTA SA User Files/User Tracks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.