I am running a Ubuntu 14.04 machine. I upgraded VirtualBox to 4.3 by first deleting the old one (as here), then installed 4.3.

While installing the ubuntu software center's progress icon kept spinning even after the progress bar had completed. I tried to start virtualbox by searching its name from the top left menu (I don't what that menu is called). After that the ubuntu software center finished installation for virtualbox 4.3. A weird thing happened at this point; the icon for the ubuntu software center changed to a question mark. At this point it didn't seem like a problem.

I tried a reboot of my system, and now there is no menu bar and no side bar (which appears to the left).

Can anyone help me out ? What did I mess up ?


I provided the link I used to solve this problem. At first the desktop came back to normal, but virtualbox was no longer installed. So I tried installing virtualbox-4.3.12 again, this time waiting patiently for it to finish. The problem occured again.

Is VirtualBox-4.3.12 not ready for Ubuntu-14.04 ? The unity package somehow gets uninstalled automatically. I have to reinstall it again and apply the solution in the answer. Also the ubuntu software center gets uninstalled.


1 Answer 1


I solved it using this solution. It suggests running compiz and enabling the unity plugin.

Not the answer you're looking for? Browse other questions tagged or ask your own question.