I have a Toshiba c55 i5 with Ubuntu installed. I was looking in the BIOS and I made a change from boot mode UEFI to the other mode "OCM " or " OSM ". Now when I turn on my computer, I get this error message:

reboot and select proper boot device or insert boot media in selected boot device and press a key

I turned it back to UEFI mode but without any change. I even tried to boot it on cd/usb of windows but without any change. What should I do?


I suspect the option you selected was the Compatibility Support Module (CSM), which is a fancy way of saying you enabled BIOS (aka legacy) support. Note that most modern computers don't have BIOSes, no matter what the manufacturers say; they have EFIs, which are completely different. Referring to them as BIOSes just causes confusion, IMHO. They can boot BIOS-mode OSes through the CSM, which is to EFI much like what dosemu or WINE is to Linux.

If your firmware interpreted the activation of CSM as an "only-use-CSM" sort of thing, that would explain why you'd be unable to boot once you activated the CSM -- you probably had no BIOS-mode boot loader installed, so it would be like telling Linux to launch WINE and no other native Linux programs when you have no Windows programs installed -- useless.

Once you de-activated the CSM, the computer should have begun booting again; but it's conceivable yours has a bug that causes it to forget its EFI boot entries after you've activated the CSM; or maybe the CSM remained active, with its boot entry at the top of the EFI's list. I can suggest four possible solutions at this point:

  • Enter your firmware setup utility and look for a boot-order option. If you see an entry called "Ubuntu," move it to the top of the boot list.
  • Enter your firmware's built-in boot manager (typically by pressing some function key other than the one you use to enter the setup utility). If there's an "Ubuntu" entry, use it. If Ubuntu boots, you can then use efibootmgr to reset Ubuntu to the top of the boot list. You would first type sudo efibootmgr to get a list of boot options. Note the number associated with the Ubuntu entry -- for instance, it might be Boot0005. You'd then type sudo efibootmgr -o 5 to make "Ubuntu" (actually GRUB) the default boot loader. (You can specify a set of boot loaders to be tried in order, as in sudo efibootmgr -o 5,1,2 to use 5, then 1 if that fails, then 2 if both 5 and 1 fail.)
  • Download the USB flash drive or CD-R version of my rEFInd boot manager and create a suitable boot medium from it. You can then boot to it (using a function key to access your computer's built-in boot manager). If you can boot Linux in this way, you can then either use efibootmgr (as above) to reset GRUB as the default or install the Debian-package version of rEFInd (directly or via a PPA; see the rEFInd page for details) to make rEFInd your default boot manager.
  • Run the Boot Repair tool. This is an easy solution on the surface, but this tool often does more than it needs to do, which can occasionally cause follow-on problems.
  • What about remove BIOS battery or using BIOS reset switch to discard changes made? I don't think boot is bad... and maybe is the boot order. I see also some boot orders with sub-selections of devices by type. – m3nda May 18 '14 at 19:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.