I know this problem has been stated before, but none of the solution worked for me. I'm running Ubuntu 14.04 on a Asus U32 laptop, alongside Windows 8. Recently I've updated from 12.04 to 14.04 and the wifi can't be enable now. Before upgrading, it worked perfectly. I have no hardware button to switch it on/off, so it must be software related. On windows 8 the wifi is working ok.

I've tried Fn+F2 to enable it, but it also goes on for about 1 second. Also, I've tried the rfkill unblock command in terminal, but nothing.

I don't know what else should I try.


2 Answers 2


Please copy and paste this command:

echo "options asus_nb_wmi wapf=1" | sudo tee /etc/modprobe.d/asus_nb_wmi.conf

Reboot and wifi should work.

you may have to toggle your fn keys to remove the hard block after rebooting.

Here is the link with full details courtesy of varun and chili555. http://ubuntuforums.org/showthread.php?t=2181558


I faced smiler problem with my asus laptop. Just download driver from below link and install It work for me Ubuntu 14.10 asus lapi


  • 1
    Welcome to Ask Ubuntu, could you please explain in a little more detail what this driver does and how to compile it for the sake of clarity? Mar 30, 2015 at 14:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .