0

This is my first time using Ubuntu from Windows and I have just installed Ubuntu 14.04, which I think is excellent.

The only problem is my ATI Radeon 3800 HD Graphics Card that I cannot get installed. I have tried everything I can think off for instance I have downloaded the driver from the AMD website and when I tried to install it AMD says I don't have any supported drivers.

After restarting my computer the screen then goes into big mode and I can't change it back to the original screen setting. I even tried using the terminal, but this does not even appear/open. I have to keep putting in the recovery disc and change back to VGA mode.

I just wonder if Ubuntu does not support this graphics card at all. I have also tried updating the additional drivers.


Edit:

Didn't know they where worse than AMD. im really stuck when i downgrade. Please see the output below:

sudo aticonfig --initial -f  
sudo: aticonfig: command not found  

john@john-ThinkCentre-XXXX:~$ sudo dpkg -i fglrx*.deb  
dpkg: warning: downgrading fglrx from 2:13.350.1-0ubuntu2 to 2:12.104-0ubuntu1  
(Reading database ... 179503 files and directories currently installed.)  
Preparing to unpack fglrx_12.104-0ubuntu1_i386.deb ...  
Removing all DKMS Modules
Done.
Unpacking fglrx (2:12.104-0ubuntu1) over (2:13.350.1-0ubuntu2) ...
dpkg: warning: downgrading fglrx-amdcccle from 2:13.350.1-0ubuntu2 to 2:12.104-0ubuntu1
Preparing to unpack fglrx-amdcccle_12.104-0ubuntu1_i386.deb ...
Unpacking fglrx-amdcccle (2:12.104-0ubuntu1) over (2:13.350.1-0ubuntu2) ...
dpkg: warning: downgrading fglrx-dev from 2:13.350.1-0ubuntu2 to 2:12.104-0ubuntu1
Preparing to unpack fglrx-dev_12.104-0ubuntu1_i386.deb ...
Unpacking fglrx-dev (2:12.104-0ubuntu1) over (2:13.350.1-0ubuntu2) ...
Setting up fglrx (2:12.104-0ubuntu1) ...
Loading new fglrx-12.104 DKMS files...
Building only for 3.13.0-24-generic
Building for architecture i686
Building initial module for 3.13.0-24-generic
Error! Bad return status for module build on kernel: 3.13.0-24-generic (i686)  
Consult /var/lib/dkms/fglrx/12.104/build/make.log for more information.update-initramfs: deferring update (trigger activated)
Processing triggers for ureadahead (0.100.0-16) ...
Processing triggers for bamfdaemon (0.5.1+14.04.20140409-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Setting up fglrx-amdcccle (2:12.104-0ubuntu1) ...
Setting up fglrx-dev (2:12.104-0ubuntu1) ...
Processing triggers for initramfs-tools (0.103ubuntu4.1) ...
update-initramfs: Generating /boot/initrd.img-3.13.0-24-generic
Processing triggers for libc-bin (2.19-0ubuntu6) ...

john@john-ThinkCentre-XXXX:~$ sudo aticonfig --initial -f
sudo: aticonfig: command not found
  • 1
    Welcome to Ask Ubuntu! Did you check if all the system requirements mentioned in the release notes of the driver were met? And also did you completely update your PC before attempting to install the driver? – VenkiPhy6 May 18 '14 at 7:33
  • Also please elaborate on - "The screen goes into big mode" .. – VenkiPhy6 May 18 '14 at 7:35
  • 1
    From what I see in the recent release notes ( support.amd.com/en-us/kb-articles/Pages/… ) your graphic card aint supported... – VenkiPhy6 May 18 '14 at 7:38
  • Sorry, when i said the screen goes big what i meant to say was that the screen was big that i could not see the top menu or the side bar. When i even pressed for the shortcut to terminal ctl alt t that wouldn't even come up. – hillsongperth May 18 '14 at 13:31
  • 1
    Hmm... maybe it means your graphic card ain't supported by the driver you installed. Check out my answer below.. – VenkiPhy6 May 18 '14 at 13:46
1

So far as I know, your graphic card is not supported my AMD. So installing the proprietary driver would not work. Therefore you need to downgrade your X server and install the Legacy driver.(See this)

But I would suggest you use the open source drivers itself. If your Ubuntu install is not detecting your maximum screen resolution with open source driver(and that is why you are trying to install the driver from AMD site)then follow this answer.

  • Ive started using the opensource driver as AMD did not support the driver yet. – hillsongperth Dec 16 '18 at 9:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.