6

I'm just getting started with Ubuntu here, so please bear with me :) I installed Ableton 9 Live Suite using PlayOnLinux, and I cannot apply the patch. The patch maker I downloaded generates a .auz file and I haven't been able to apply nor dragging it to Ableton nor through Terminal.

This is what I've tried:

  • Dragging the file: it rejects it saying the authorization file is not valid on this computer (or system, I'm not sure what term it uses, I'm running this in Spanish). I've tried running Ableton using Wine and not through PlayOnLinux, but no go.

  • Terminal:

    wine ableton 9 live suite.exe "c:\programdata\ableton\live 9 suite\program\authorize.auz"
    

    The ableton exe file is located in:

    .PlayOnLinux/wineprefix/AbletonLive9/drive_c/users/Public/Application Data/Ableton/Live 9 Suite/Program
    

    and the reply I get is:

    wine: cannot find L"C:\\windows\\system32\\ableton.exe
    
  • Did you check appdb.winehq.org/…? – Braiam May 18 '14 at 3:15
  • Braiam, hey! I that's where I got the authorization instructions, which I tried to adapt to my situation. Have I done it wrong? – user282686 May 18 '14 at 6:48
1

The only working way is to use PlayOnLinux.

Install Ableton (in win7 mode via configure wine). You can open it in trial mode to download the factory pack. close it.

Now install a non listed application in PlayOnLinux select the ableton 9 drive location and launch the patch.

Patch the ableton exe (it will ask for the file location) and explore the ~/PlayOnLinux's virtual drives/AbletonLive9/drive_c/ProgramData/Ableton/Live 9 Suite/Program/ directory to find the .auz file (keep this folder opened)

Open ableton from PlayOnLinux, drag and drop the auz file and wait.

Ableton will register normally.

Beware of update preferences in ableton. By default it's set to auto update. Untick the automatic update will help.

You must create a folder in your abletonlive9 drive C to export your projects or ableton will crash when saving a project.

0

I had this exact problem yesterday. Steps that worked for me:

  1. Create a new 64-bit Wine prefix using Winetricks and install Gecko and Mono.

  2. In the winetricks window, select default Wineprefix.

  3. Under install a component or Windows DLL, install all the Visual C++ packages up to 2015 and Quicktime72.

  4. Install Ableton Live 9, and then turn off automatic updates or usage data. (Block ABL in a firewall like ufw if you want to be very thorough).

  5. Decompress PatchIO, and move it to .wine/drive_c/ProgramData/Ableton/Program or whatever it is where the executable for Ableton lives in your wine prefix.

  6. Close Ableton, then run the PatchIO.exe.

  7. Reopen Ableton and the authorization window should come up.

  8. Click 'No Internet on this Computer' in the lower left corner of the window.

  9. Some instructions appear on this page; Drag the Authorization.auz file into the middle of this window.

  10. There should be a dialog box that says that you're authorized.

Dragging it onto the app icon or piping it into the app from the command line does not seem to work under Wine. It just doesn't know what to do with that file type.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.