0

I just upgraded my 64 bit AMD desktop Xubuntu to 14.04 after easy, successful upgrades of 2 other machines to Lubuntu. There were numerous errors during the upgrade and now it seem to be in an almost unusable state. I cannot su without getting a segmentation fault and the Software Updater crashes. Skype doesn't work with Pulse Audio - no sound output.

I might add that there was a question about retaining the root privileges or replacing them during the installation. I tried to answer KEEP but was warned that this could cause problems so I answered REPLACE.

Also I saw something about encryption of the disk device and, if the key is different from the previous release this could cause problems.

1 Answer 1

1

I solved the segfault problem as follows:

logged in as root using ssh root@localhost
ran apt-get update, which complained about duplicate sources:

W: Duplicate sources.list entry http://archive.canonical.com/ubuntu/ trusty/partner amd64 Packages (/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_trusty_partner_binary-amd64_Packages)
W: Duplicate sources.list entry http://archive.canonical.com/ubuntu/ trusty/partner i386 Packages (/var/lib/apt/lists/archive.canonical.com_ubuntu_dists_trusty_partner_binary-i386_Packages)

I then backed up /etc/apt/sources.list and commented out the lines for partner repositories.

I then ran

apt-get update
apt-get upgrade
apt install -f

After that I could su and sudo.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.