6

I am attempting to install Ubuntu on my Macbook Pro, but when I attempt to download the Mac desktop image (as opposed to the regular 32bit or 64bit edition) from the normal Ubuntu websire, I am given a 404 Error from all mirrors. It seems this image does not exist for 14.04. I have found the image for 14.10, but I would prefer to use a LTS edition. Does anyone know where I can find this image?

1

3 Answers 3

5

The Mac .iso files existed for saucy (releases.ubuntu.com/saucy), but do not appear to to exist for trusty (releases.ubuntu.com/trusty).

Did the Mac specific elements get merged with the standard 32 and 64bit versions?


Further Research:

see response to: What is different about the Mac ISO image?

In Ubuntu 10.10, we changed the normal amd64 CD images to dual-boot on either BIOS or UEFI systems (UEFI, "Unified Extensible Firmware Interface", is a different kind of firmware found on many newer systems). This was done using a technique known as a "multi-catalog" CD - it contains two boot images, and the specification says that the firmware is supposed to pick the one it can best use.

Unfortunately, even though Macs use a variant of EFI (an earlier version of what's now called UEFI), they apparently can't cope with multi-catalog CDs, and simply refuse to boot them. This left us in rather a quandary: we needed to support UEFI systems, but we didn't want to drop support for Macs either. I therefore created the amd64+mac CD images, which are exactly the same as the amd64 images except that they only support BIOS booting. Macs are happy to boot these in their BIOS emulation mode.

(In fact, the name amd64+mac is a slight misnomer, because it later turned out that some systems other than Macs suffer from a similar problem - but I felt that a more technically accurate naming such as amd64+nouefi would be more likely to confuse than enlighten.)

This blog From an Egg > How to install Ubuntu on a Mac or Macbook also suggests using the standard iso files.

Download Ubuntu 14.04 LTS Trusty Tahr. .. Be sure you download the iso which does NOT have ‘+mac’ in the filename. This is for older Apple computers.

And finally this Kubuntu support thread Why is there no longer a +mac .iso available for download? gives a similar explanation:

.. there was some overlap with the OS X versions, the late 10.4.x thru 10.7.5 works with early intel mac's 32-bit EFI, but otherwise 64-bit systems. (those mac's would boot thru the 32-bit EFI, and run the 64-bit kernal). Apple sold these as "Fully" 64-bit machines, when in fact they were limited by the EFI used, when confronted Apple downplayed it. They built in obsolescence in two areas one the EFI, the second graphics cards. Both issues can be worked around on the MacPro's.

Conclusion:

You should be using the standard 64bit (or 32bit) image, unless you are using an older model.

2
  • I don't have a Mac platform to test any of this from, so was just providing information. The first link / reference is by the person who developed the +mac .iso files, so is authorative.
    – david6
    May 18, 2014 at 0:31
  • yes I know him and why he had to make a mac specific iso, they invariably the same. however if one merely navigates to ubuntu.com and goes to download or indeed search engines they wind up at ubuntu.com/download/desktop which does have the mac version as an option. I guess I dont know the difference between the releases.ubuntu and the download page 99% of users wind up on. Either way if I read your answer when I had my problem I would have wound up downloading saucy and not trusty for my macbook pro :( May 18, 2014 at 5:40
1

To install Ubuntu 14.04 LTS on a mac go here: http://www.ubuntu.com/download/desktop

However that site appears to have broken links so here is a direct link to the .iso file:

http://cdimage.ubuntu.com/releases/14.04/release/ubuntu-14.04-desktop-amd64+mac.iso

if you prefer torrent (which is a safer habbit) here is the link

http://cdimage.ubuntu.com/releases/14.04/release/ubuntu-14.04-desktop-amd64+mac.iso.torrent

THE ABOVE FILES ARE WHAT I USED FOR MY Macbook Pro and worked successfully

My model is the Macbook Pro 2008 Original, read the other answer also.. it may help you.

0
0

iso files with the +mac in their file names for 14.04 can be found here:

http://cdimage.ubuntu.com/releases/14.04/release/

The old direct links to files in that location are broken because they point to 14.04 files instead of 14.04.3 or 14.04.4, which replaced that older version. So just visit the directory link above and pick the file you want yourself.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .