I recently upgraded from Maverick to Natty on a dual boot with Windows XP. My Internet worked great at first, but more and more frequently I have been experiencing slow connection, not just on the browser, but with any application that connects to the Internet. The connection works fine on Windows, which is what I'm using right now.

I looked up my problem on Google. Based on my search results, it seems like a common problem. I found something about disabling IPv6. I did so, but the connection did not seem to get any faster.

I'd greatly appreciate any thoughts on what to do. I've tried a couple of other methods, but was unsatisfied with the results; the connection did not become any faster.


I tried the method shown here, hoping this might work for me, but now I can't connect to the Internet at all. The "Network Connections" button in "System Settings" is also gone, so I can't edit my connections anymore. Did anyone also have the same thing happen? I'm considering re-installing Maverick.

  • 1
    This has been covered multiple times on this site. I'm inclined to think your question is a duplicate. Jun 4, 2011 at 2:34
  • Tried unplugging and "rebooting" your router? It can get slowed down (especially if it's a Linksys router:) Restarting it helps most of the time (it that's the prob. here). Jun 4, 2011 at 9:59
  • My apologies, @marco. I've looked at the similar questions, but they have not worked for me. I've also looked on Google, but most of them either do not apply to me, or do not work. I will try to be less redundant next time. Jun 5, 2011 at 23:42

1 Answer 1


To fix your Network Connections problem, I think you need to do this:

gksu gedit /etc/network/interfaces and delete the

auto eth0
iface eth0 inet static

section, which will give control of the connection back to network manager.

Regarding the original problem:

What happens when you run ping -n Are the times between pings similar to ping google.com or is ping google.com significantly slower between pings even though the times for the ping is the nearly the same as ping -n If there is a difference, then it's most likely a DNS problem. If it is a DNS problem, you could edit your connection in network manager. Go to the IPv4 tab and pick "Automatic (DHCP) Addresses Only". Now, add "" in the DNS server field and click Save. Reconnect and see if that fixes it.

  • Hmmm... It seems that ping google.com seems much slower. Although, I edited the file and now the the Internet works, at least. Jun 14, 2011 at 15:35
  • @TreefrogInc Looks like I didn't finish my thought about network manager...I think it got cut off when I saw that network manager wasn't working :) . Give me a bit to boot into Ubuntu and I will edit my answer with the next step.
    – Azendale
    Jun 15, 2011 at 1:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .